creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Heinz Marbaise <khmarba...@gmx.de>
Subject Re: [jira] [Commented] (RAT-220) JDK version 1.6
Date Sun, 11 Sep 2016 21:20:00 GMT
Hi,

On 11/09/16 23:03, Karl Heinz Marbaise wrote:
> Hi,
>
> On 11/09/16 20:59, Javen O'Neal wrote:
>> While increasing the minimum supported version does cut out some users
>> who
>> are running ancient versions of Java,
>
> To be honest 1.5 Java is out of date how long? Furthermore no security
> updates etc. and no enterprise contracts possible anymore...for JDK 5...
>
>
>> it also opens the door to better
>> language features.
>
> I think there are many things which can be improved...independent of the
> language features..(for example creating a release easier, make a
> publishing of the site easier etc. only those which I have seen the last
> weeks and where I'm trying to improve. I have not yet taken deeper looks
> into the code etc.)...
>
>
>>  If the new features are used, it may be easier for
>> potential developers to read the code, contribute, and find bugs that are
>> disguised by the more verbose syntax of Java 1.5
>
> If a developer is not able to read Java Code in 1.5 etc. sorry...but
> such old code which plunge some developers...but this is a different
> story...
>
>>
>> You should consider both RAT developers and users when thinking about an
>> upgrade.
>
> That's exactly what I'm doing...cause users require more features
> shorter release cycles etc.
>
> For example at the maven project we have the JDK 6 minimum for plugins
> and for Maven version 3.3+ JDK 7
>
>>
>> That said, Sebb is right that you should not increase the version without
>> significant thought, as it WILL abandon some users.
>
> Does some of those PMC's tried to get the download statistics from Maven
> Central to see how many users we are talking about?

So I have taken a look:

For rat-tasks it looks like this:

http://chart.apis.google.com/chart?cht=lc&chs=800x200&chco=326A9E&chxt=x,y&chtt=Downloads+Over+the+Last+12+Months+For+org.apache.rat:apache-rat-tasks&chxr=1,0,10046&chds=0,10046&chxs=1N*s*&chls=3&chm=o,0066FF,0,-1,10,0&chd=t:10046,7911,7334,8166,7378,7191,7806,7354,6095,5878,5512,4716&chxl=0:|Sep2015|Oct2015|Nov2015|Dec2015|Jan2016|Feb2016|Mar2016|Apr2016|May2016|Jun2016|Jul2016|Aug2016

This is a trend downwards...

If you take a look at the apache-rat-plugin:

http://chart.apis.google.com/chart?cht=lc&chs=800x200&chco=326A9E&chxt=x,y&chtt=Downloads+Over+the+Last+12+Months+For+org.apache.rat:apache-rat-plugin&chxr=1,0,49322&chds=0,49322&chxs=1N*s*&chls=3&chm=o,0066FF,0,-1,10,0&chd=t:22639,19349,19777,21495,23567,26233,27893,34669,47337,42225,39914,49322&chxl=0:|Sep2015|Oct2015|Nov2015|Dec2015|Jan2016|Feb2016|Mar2016|Apr2016|May2016|Jun2016|Jul2016|Aug2016

Trend is upwards...10 times greater than ant-task ?...

Kind regards
Karl Heinz

>
>
> RAT 0.12 requires Java 1.5 so it's time to say good by to JDK 1.5...
>
> If really someone will find an issue with 0.12 and really needs a bug
> fix we can simply think about creating a branch and produce a 0.12.1 ?
> So I don't see any problem with that...
>
> Apart from that the whole project has not yet reached 1.0.0 state...
>
>> If the only problem for
>> being on different versions is a more complicated compatibility statement
>> on your web page,
>
> It's not a problem but shows the inconsistency of the project line...
>
> A simple statement like
> RAT, Whiskers and Tentacle use JDK 1.6+ is simple and clear for users...
>
>
>> then leave this issue at that. "The Creadur project
>> consists of three modules: RAT, Whiskers, and Tentacles.
>
>
>> RAT requires Java 6+.
>
> RAT requires Java 1.5 and not 1.6 based on the build
>
>> Whiskers and Tentacles requires Java 7+."
>
> Whiskers as well as Tentacles require 1.6 based on the build...
>
>
> So that was my suggestion to increase the minimum JDK versions which is
> needed to run/build RAT/Tentacles/Whiskers to JDK 6...make at least one
> release and move forward to JDK 7 make another release and move forward
> to JDK 8...This means you have always a base release on which you can
> make bug fix (or if really needed backports) releases for the
> appropriate JDK requirements...
>
> Not to talk about JDK 9 next year (which is not very far in the future)...
>
> Apart from that Tentacles as well as Whiskers need releases at all...
> cause I can't see any release on Maven Central of them...
>
> Tentacles shows 0.1-SNAPSHOT ? (if the bottom line is related 2012?) ?
> Whiskers shows 0.1-SNAPSHOT (last updated 2013 ?)
>
> For RAT that 0.12 has been released about three months ago,  but before
> that it has taken 2 years for a release ? I think this is the problem
> not the users...
>
>
>
>>
>> On Sep 11, 2016 11:40 AM, "P. Ottlinger" <pottlinger@apache.org> wrote:
>>
>>> Hi!
>>>
>>> I tried bringing up this issue more than once, thus I was very happy
>>> that somebody else feels the same.
>>>
>>> In 0.12 we had a contribution that added a Gradle plugin. It failed due
>>> to insufficient dependencies with JDK5.
>
> If we had such things that makes it really clear to move forward...
>
>
>>>
>>> Thus there's a need to update .... if we want to stay relevant.
>>>
>>> If we are happy with some rather old users with Ant and JD5 - ok,
>
> I have my doubts that Ant users user really use JDK 5 apart from that if
> you look at the Ant project they have decided jump directly to JDK 8
> minimum ...1.9.X has been the last which is JDK 5 compatible...
>
>
>
>
>>> but to my mind we should add Gradle support to stay relevant in the ASF
>>> sphere.
>
> Which is relevant in other ways as well...apart of the plan to move to
> Kotlin for Gradle 4.X ?
>
>
> Kind regards
> Karl Heinz Marbaise
>
>
>>>
>>> Just my 2 ct
>>> Phil
>>>
>>> Am 11.09.2016 um 14:56 schrieb Sebb (JIRA):
>>>>
>>>>     [ https://issues.apache.org/jira/browse/RAT-220?page=com.
>>> atlassian.jira.plugin.system.issuetabpanels:comment-
>>> tabpanel&focusedCommentId=15481714#comment-15481714 ]
>>>>
>>>> Sebb commented on RAT-220:
>>>> --------------------------
>>>>
>>>> +1
>>>>
>>>> We should not change the Java version merely to be consistent with
>>>> other
>>> Creadur projects.
>>>>
>>>> There needs to be a clear end-user benefit to requiring the upgrade.
>>>>
>>>>> JDK version 1.6
>>>>> ---------------
>>>>>
>>>>>                 Key: RAT-220
>>>>>                 URL: https://issues.apache.org/jira/browse/RAT-220
>>>>>             Project: Apache Rat
>>>>>          Issue Type: Improvement
>>>>>            Reporter: Karl Heinz Marbaise
>>>>>            Assignee: Jochen Wiedmann
>>>>>
>>>>> Currently the RAT project defines as Java compatibility 1.5 but
>>> Tentacles defines 1.6 and Whiskers as well 1.6 so it would be a good
>>> idea
>>> to go to 1.6 as minimum....If someone needs to work with 1.5
>>> toolchain can
>>> be used.
>>>>
>>>>
>>>>

Mime
View raw message