creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "P. Ottlinger" <pottlin...@apache.org>
Subject Re: [jira] [Commented] (RAT-216) Update versions in pom after release of 0.12 and update dependencies
Date Mon, 22 Aug 2016 21:48:22 GMT
Hi Jochen,

thanks for verifying that the problems I tried to report in May
(subject: update to newest apache-parent pom yields problems with maven
enforcer, from: 2016-05-21 ) are still there.

My comment (in the task) was there to avoid additional nodes why I did
not update the ASF parent.

Feel free to open another bug in case you want the new ASF pom.

IMHO RAT-216 is done, all builds (site/install) work fine.

Cheers,
Phil


Am 22.08.2016 um 09:44 schrieb Jochen Wiedmann (JIRA):
> 
>     [ https://issues.apache.org/jira/browse/RAT-216?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15430253#comment-15430253
] 
> 
> Jochen Wiedmann commented on RAT-216:
> -------------------------------------
> 
> Please clarify that statement:
> 
>   We are unable to update to the latest ASF parent pom since it brings in incompatible
(newer) dependency versions
>   that clash with our compiler settings.
> 
> AFAICT, the parent pom cannot bring any dependencies into a project, apart from specifying
versions in dependencyManagement.
> 
> Besides, the child can always overrule its parent.

Mime
View raw message