creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philipp Ottlinger (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (RAT-158) SAXParser warnings
Date Tue, 23 Feb 2016 22:08:18 GMT

    [ https://issues.apache.org/jira/browse/RAT-158?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15159749#comment-15159749
] 

Philipp Ottlinger commented on RAT-158:
---------------------------------------

Thanks for the update - newer versions seem use a JDK that is too new for RAT :-(
{code}
[INFO] --- maven-enforcer-plugin:1.3.1:enforce (enforce-bytecode-version) @ apache-rat-plugin
---
[INFO] Artifact org.apache.maven.doxia:doxia-core:jar:1.7:compile contains .class compiled
with incorrect version
[INFO] Artifact org.apache.maven.doxia:doxia-logging-api:jar:1.7:compile contains .class compiled
with incorrect version
[INFO] Artifact org.apache.maven.doxia:doxia-sink-api:jar:1.7:compile contains .class compiled
with incorrect version
[WARNING] Rule 0: org.apache.maven.plugins.enforcer.EnforceBytecodeVersion failed with message:
Found Banned Dependency: org.apache.maven.doxia:doxia-core:jar:1.7
Found Banned Dependency: org.apache.maven.doxia:doxia-logging-api:jar:1.7
Found Banned Dependency: org.apache.maven.doxia:doxia-sink-api:jar:1.7
Use 'mvn dependency:tree' to locate the source of the banned dependencies.
{code}

Until that decision is changed we cannot switch over to the new version.

Verified with the following changes
{code}
Index: apache-rat-plugin/pom.xml
===================================================================
--- apache-rat-plugin/pom.xml   (Revision 1731969)
+++ apache-rat-plugin/pom.xml   (Arbeitskopie)
@@ -33,7 +33,7 @@
   </prerequisites>
   <properties>
     <currentVersion>${project.version}</currentVersion>
-    <doxiaVersion>1.6</doxiaVersion>
+    <doxiaVersion>1.7</doxiaVersion>
     <doxiaSitetoolsVersion>1.6</doxiaSitetoolsVersion>
   </properties>
   <build>
Index: pom.xml
===================================================================
--- pom.xml     (Revision 1731969)
+++ pom.xml     (Arbeitskopie)
@@ -329,17 +329,11 @@
           <artifactId>apache-rat-plugin</artifactId>
           <!-- Must use previous version, to avoid a cyclic reference -->
           <version>${previousRatVersion}</version>
-          <dependencies><!-- TODO remove exclusion when upgrading to new ASF parent
or doxia release (RAT-158) -->
+          <dependencies>
             <dependency>
               <groupId>org.apache.maven.doxia</groupId>
               <artifactId>doxia-core</artifactId>
-              <version>1.2</version>
-              <exclusions>
-                <exclusion>
-                  <groupId>xerces</groupId>
-                  <artifactId>xercesImpl</artifactId>
-                </exclusion>
-              </exclusions>
+              <version>1.7</version>
             </dependency>
           </dependencies>
           <configuration>
{code}
 and
{code}
mvn clean install site:site
{code}

> SAXParser warnings
> ------------------
>
>                 Key: RAT-158
>                 URL: https://issues.apache.org/jira/browse/RAT-158
>             Project: Apache Rat
>          Issue Type: Bug
>    Affects Versions: 0.10
>         Environment: Apache Maven 3.0.4
> Maven home: /usr/share/maven
> Java version: 1.6.0_30, vendor: Sun Microsystems Inc.
> Java home: /usr/lib/jvm/java-6-openjdk-amd64/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "linux", version: "3.11.0-17-generic", arch: "amd64", family: "unix"
>            Reporter: John Vines
>            Assignee: Philipp Ottlinger
>            Priority: Minor
>             Fix For: 0.12
>
>         Attachments: RAT-158-2.patch, RAT-158.patch
>
>
> I have rat configured as such
> {code} <plugin>
>          <groupId>org.apache.rat</groupId>
>          <artifactId>apache-rat-plugin</artifactId>
>          <inherited>false</inherited>
>          <executions>
>            <execution>
>              <phase>verify</phase>
>              <goals>
>                <goal>check</goal>
>              </goals>
>            </execution>
>          </executions>
>          <configuration>
>            <excludes>
>              <exclude>**/conf/**</exclude>
>            </excludes>
>          </configuration>
>        </plugin>
> {code}
> And with every build where it triggers, I see 
> {code}
> Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit'
is not recognized.
> Warning:  org.apache.xerces.parsers.SAXParser: Feature 'http://javax.xml.XMLConstants/feature/secure-processing'
is not recognized.
> Warning:  org.apache.xerces.parsers.SAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit'
is not recognized.
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message