creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hervé Boutemy (JIRA) <j...@apache.org>
Subject [jira] [Commented] (RAT-158) SAXParser warnings
Date Fri, 20 Feb 2015 02:38:12 GMT

    [ https://issues.apache.org/jira/browse/RAT-158?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14328485#comment-14328485
] 

Hervé Boutemy commented on RAT-158:
-----------------------------------

yes, the patch applies to the IT test code only: that does make sense to me, since I did not
find any IT testing the report inside a site (notice there is still no IT testing the report
as mojo)

the patch shows what other users of RAT can do to avoid the warning when they use RAT inside
their site: no generic patch can be created for that, since it has to be done on user's pom.xml

but, for sure, you can totally ignore the second patch, since it does not give any real fix
on RAT: RAT is now fixed (with the dependency exclusion workaround), even if the report inside
a site generation still generates warning.

Apply the second patch or not won't change anything: but you can close this issue since you
can't do anything more on the topic in RAT code

> SAXParser warnings
> ------------------
>
>                 Key: RAT-158
>                 URL: https://issues.apache.org/jira/browse/RAT-158
>             Project: Apache Rat
>          Issue Type: Bug
>    Affects Versions: 0.10
>         Environment: Apache Maven 3.0.4
> Maven home: /usr/share/maven
> Java version: 1.6.0_30, vendor: Sun Microsystems Inc.
> Java home: /usr/lib/jvm/java-6-openjdk-amd64/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "linux", version: "3.11.0-17-generic", arch: "amd64", family: "unix"
>            Reporter: John Vines
>            Priority: Minor
>             Fix For: 0.12
>
>         Attachments: RAT-158-2.patch, RAT-158.patch
>
>
> I have rat configured as such
> {code} <plugin>
>          <groupId>org.apache.rat</groupId>
>          <artifactId>apache-rat-plugin</artifactId>
>          <inherited>false</inherited>
>          <executions>
>            <execution>
>              <phase>verify</phase>
>              <goals>
>                <goal>check</goal>
>              </goals>
>            </execution>
>          </executions>
>          <configuration>
>            <excludes>
>              <exclude>**/conf/**</exclude>
>            </excludes>
>          </configuration>
>        </plugin>
> {code}
> And with every build where it triggers, I see 
> {code}
> Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit'
is not recognized.
> Warning:  org.apache.xerces.parsers.SAXParser: Feature 'http://javax.xml.XMLConstants/feature/secure-processing'
is not recognized.
> Warning:  org.apache.xerces.parsers.SAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit'
is not recognized.
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message