creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: Jenkins jobs are fixed for Rat
Date Wed, 05 Nov 2014 13:16:08 GMT
I agree that we should not drop support for Java 5.

I have added both Animal Sniffer and Maven Enforcer in place to make
sure that we don't use Java 6 stuff.

For 0.11 I used Java 5 to build the release.

On Wed, Nov 5, 2014 at 10:08 AM, Jochen Wiedmann
<jochen.wiedmann@gmail.com> wrote:
> Two basic considerations:
>
> - In general, if there is no compelling reason, we shouldn't drop
> support for major Java versions.
> - If we do support Java 5 at runtime, we shouldn't use Java 6 to build
> and test it. We might miss
>   incompatibilities otherwise.
> - That said, obtaining a Java 5 JDK is a non-trivial thing today. So I
> wonder whether we should stick
>    to 5.0 for the runtime version?
>
> I'm not in favour of one or the other. I'd just vote that we be consistent.
>
> Jochen
>
>
> On Tue, Nov 4, 2014 at 11:44 PM, P. Ottlinger <pottlinger@apache.org> wrote:
>> Hi,
>>
>> Am 04.11.2014 um 23:14 schrieb Dennis Lundberg:
>>> I've changed our Jenkins jobs for Rat, so that they now use Java 6.
>>> That made our builds succeed again.
>>
>> I thought there were strong arguments for staying with Java5 and
>> ensuring that RAT builds with Java5 ?!
>>
>> Are these objections gone now?
>>
>> Thanks for fixing the builds; I suspected the infrastructure to be
>> instable again since my commits didn't change pom files.
>>
>> Cheers,
>> Phil
>>
>
>
>
> --
> Our time is just a point along a line that runs forever with no end.
> (Al Stewart, Lord Grenville)



-- 
Dennis Lundberg

Mime
View raw message