creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Lehmkühler <andr...@lehmi.de>
Subject Re: RAT excludes question
Date Thu, 13 Nov 2014 08:20:31 GMT
Hi,

> Markus Weimer <markus@weimo.de> hat am 13. November 2014 um 02:50 geschrieben:
> 
> 
> Hi,
> 
> I am trying to add RAT to the REEF incubation project and hit an issue 
> with excludes. I "borrowed" the following configuration from Hadoop:
> 
> ---
>                  <plugin>
>                      <groupId>org.apache.rat</groupId>
> <artifactId>apache-rat-plugin</artifactId>
>                      <version>0.7</version>
>                      <configuration>
>                          <excludes>
> <exclude>.gitattributes</exclude>
> <exclude>.gitignore</exclude>
>                              <exclude>.git/**/exclude>
Maybe it's to simple, there is a typo, a "<" is missing within the closing tag


>                              <exclude>.idea/**</exclude>
>                              <exclude>target/**</exclude>
>                          </excludes>
>                      </configuration>
>                  </plugin>
> ---
> 
> You can find the full pom.xml here:
> 
> https://github.com/markusweimer/incubator-reef/blob/reef-38/pom.xml
> 
> However, when I run `mvn rat:check`, I get lots of complaints about 
> files with missing licensing headers in the .git/ folder, e.g.:
> 
> ---
>   !????? .git/COMMIT_EDITMSG
>   !????? .git/config
>   !????? .git/description
>   !????? .git/FETCH_HEAD
> ---
> 
> I tried updating to the latest RAT version (0.10), but that didn't help 
> either. Am I doing something wrong here?
> 
> Thanks,
> 
> Markus
> 


BR
Andreas Lehmkühler

Mime
View raw message