creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Lundberg (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (RAT-158) SAXParser warnings
Date Tue, 19 Aug 2014 11:55:18 GMT

    [ https://issues.apache.org/jira/browse/RAT-158?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14102148#comment-14102148
] 

Dennis Lundberg commented on RAT-158:
-------------------------------------

Hi Phillipp,

I don't think that is the problem described in this issue. The problem is not that the value
of the limit property is wrong, but rather that the newer JDKs are setting properties that
Xerces don't know about. I had a look in the latest release of Xerces and the problem is still
there, so upgrading to that version will not work.

> SAXParser warnings
> ------------------
>
>                 Key: RAT-158
>                 URL: https://issues.apache.org/jira/browse/RAT-158
>             Project: Apache Rat
>          Issue Type: Bug
>    Affects Versions: 0.10
>         Environment: Apache Maven 3.0.4
> Maven home: /usr/share/maven
> Java version: 1.6.0_30, vendor: Sun Microsystems Inc.
> Java home: /usr/lib/jvm/java-6-openjdk-amd64/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "linux", version: "3.11.0-17-generic", arch: "amd64", family: "unix"
>            Reporter: John Vines
>            Priority: Minor
>
> I have rat configured as such
> {code} <plugin>
>          <groupId>org.apache.rat</groupId>
>          <artifactId>apache-rat-plugin</artifactId>
>          <inherited>false</inherited>
>          <executions>
>            <execution>
>              <phase>verify</phase>
>              <goals>
>                <goal>check</goal>
>              </goals>
>            </execution>
>          </executions>
>          <configuration>
>            <excludes>
>              <exclude>**/conf/**</exclude>
>            </excludes>
>          </configuration>
>        </plugin>
> {code}
> And with every build where it triggers, I see 
> {code}
> Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit'
is not recognized.
> Warning:  org.apache.xerces.parsers.SAXParser: Feature 'http://javax.xml.XMLConstants/feature/secure-processing'
is not recognized.
> Warning:  org.apache.xerces.parsers.SAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit'
is not recognized.
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message