creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [VOTE] Release Apache Rat 0.11
Date Sun, 10 Aug 2014 19:56:34 GMT
Just found out I need to add a pluginRepositories section.
I can now use the RC build.

I still get the NPE:

Caused by: java.lang.NullPointerException
    at org.apache.rat.mp.RatReportMojo.getSkinArtifactFile(RatReportMojo.java:114)
    at org.apache.rat.mp.RatReportMojo.execute(RatReportMojo.java:204)
    at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)


On 10 August 2014 20:30, sebb <sebbaz@gmail.com> wrote:
> On 10 August 2014 20:24, P. Ottlinger <pottlinger@aiki-it.de> wrote:
>> Hi Sebb,
>>
>> Am 10.08.2014 um 21:22 schrieb sebb:
>>> -1
>>> I'm seeing an NPE when running "mvn apache-rat: rat
>>> -Dcommons.rat.version=0.11" against commons-csv and commons-compress.
>>>
>>> Other times I have seen messages such as
>>>
>>> Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property
>>> 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is
>>> not recognized.
>>
>> This seems to be a JDK problem and is part of
>> https://issues.apache.org/jira/browse/RAT-158
>>
>> The NPE sucks ....
>> can you reproduce it with 0.12-SNAPSHOT just to determine if something
>> is wrong with the RC.
>
> I can reproduce it when I install from the tag or trunk.
>
> For some reason I have not been able to use any SNAPSHOT versions from
> the ASF snapshot repo.
>
> As mentioned in previous e-mail, I'm happy to try using 0.11 from the
> RC area if someone can explain how to tell Maven to use that as a repo
> when looking for 0.12
>
>> Phil
>>

Mime
View raw message