creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: Compiler level - change ?!
Date Sat, 02 Aug 2014 17:35:00 GMT
Hi Phil,

If there is no compelling reason to upgrade the minimum jdk version, we
should not do it. There is no immediate urgency to upgrade to commons-lang3
AFACT.

I would very much like to stay on Java 5 as a minimum. Most Maven plugins
are still on Java 5 and will be for some time. The Maven project are about
to start enforcing the Rat check on all its 100+ subprojects. That will not
be possible if Rat switches to require Java 6. As long as there are ASF
projects on Java 5, Rat should also be on Java 5.

--
Dennis Lundberg
Den 31 jul 2014 09:15 skrev "P. Ottlinger" <pottlinger@aiki-it.de>:

> Hi guys,
>
> due to my addition of commons-lang3 I ran into the versioning chaos of
> creadur's compiler level.
>
> Are there any hard reasons to keep with 1.5 in Jenkins?
>
> Since these ancient Java versions are not officially supported and no
> security updates for the varous security issues are available I'd like to
> rpopose to raise the compiler level in rat, tentacles and whisker ...
> what level would you prefer?
>
> - 1.6
> - 1.7
> - 1.8
>
> Thanks for your opinions/objections.
>
> I'd propose to switch to 1.7 in version 0.11 for all projects in order to
> be able to upgrade dependencies and to avoid a rag rug of compiler levels
> in all creadur projects.
>
> Cheers,
> Phil
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message