creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Burrell Donkin <robertburrelldon...@blueyonder.co.uk>
Subject Re: RAT buildbot troubleshooting (ant task)
Date Sat, 03 Aug 2013 12:52:12 GMT
On 08/02/13 23:05, Marvin Humphrey wrote:
> Hello RAT-people,

Hi Marvin

> The RAT buildbot that Infra set up for Apache Lucy has a problem -- it's not
> ignoring the contents of the .git repository directory.
>
>      http://ci.apache.org/projects/lucy/rat-output.html
>
> I sent email to builds@apache.org a week ago and I opened an INFRA Jira ticket
> yesterday.  (This isn't a new problem, FWIW -- it's been broken for
> months but I'm just getting around to dealing with it now.)
>
>      https://issues.apache.org/jira/browse/INFRA-6625

Thanks. I've added a comment.

> It would be great if we could spare Infra from having to perform
> time-consuming troubleshooting.  Do any obvious solutions present themselves
> to our resident RAT experts when they see that output?  Upgrade RAT on the
> buildslave?  Put something in our `rat-excludes` file other than `.git/*`
> (which didn't seem to help)?

I suspect that upgrading the Ant version would work, or adding a 
explicit fileset exclusion to the ant build task.

I think it would be reasonable for Rat to maintain its own additional 
list of excluded directories independent of the build platform. I've 
opened a JIRA[1] but I think that this change would deserve some 
thought. So, I'm not proposing to address this for the 0.10 Rat release.

Robert
[1] https://issues.apache.org/jira/browse/RAT-146

Mime
View raw message