creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: [DISCUSS] Minimum version of Maven to use the Rat plugin
Date Tue, 09 Oct 2012 19:48:09 GMT
On 2012-09-23 22:29, Dennis Lundberg wrote:
> Hi
> 
> In RAT-78 there is a request to upgrade to a newer version of Doxia.
> That is a reasonable request given the fact that the current version we
> are using is 1.0-alpha-8 which is *really* old.
> 
> Now, in order to decide which version of Doxia to use we need to first
> define the minimum version of Maven we want to support. Currently our
> plugin requires Maven 2.0.6 which came out in 2007. Over in Maven land
> we currently target Maven 2.2.1 as the minimum version for our plugins.
> 
> The reason for this question is because different versions of Maven
> comes with different versions of Doxia. This is an unfortunate hard
> connection between the two, but starting with Maven 3 there are no
> longer any direct dependencies on Doxia in Maven core. See this wiki
> page for some history in the matter:
> 
> http://docs.codehaus.org/display/MAVEN/Doxia+Release+Plan
> 
> We really only have two choices:
> 
> 1. Require Maven 2.0.11 and use Doxia 1.0.x
> 
> 2. Require Maven 2.1.0+, which in reality means Maven 2.2.1 due to
> technical reasons I won't go into here, and use Doxia 1.1+
> 
> Unless anyone has strong objections I plan on going with option 2 here.

Done, I went with Doxia 1.2.


-- 
Dennis Lundberg

Mime
View raw message