creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chip Childers <chip.child...@sungard.com>
Subject Re: Issue with the Whisker CLI
Date Thu, 16 Aug 2012 20:38:47 GMT
On Thu, Aug 16, 2012 at 4:01 PM, Chip Childers
<chip.childers@sungard.com> wrote:
> 2 - In the following example, the copyright notice is not being added
> to the LICENSE file output:
>
> Assume the ApacheLicenseVersion2 exists above this snippet.  Also
> assume the org for Clinton Begin exists.
>
> [snip...]
>     <primary-license id='ApacheLicenseVersion2'>
>         <copyright-notice>Copyright (c) 2012 The Apache Software
> Foundation</copyright-notice>
>     </primary-license>
>     <organisations>
>         <organisation
>             id='apache.org'
>             name='The Apache Software Foundation'
>             url='http://www.apache.org/'/>
>         <organization
>             id='person:Clinton.Begin'
>             name='Clinton Begin'
>             url='http://code.google.com/p/mybatis/' />
>     </organisations>
>     <within dir='utils/src/com/cloud/utils/db'>
>         <with-license id='ApacheLicenseVersion2'>
>             <copyright-notice>
> Copyright (c) 2004 Clinton Begin
>             </copyright-notice>
>             <by-organization id="person:Clinton.Begin">
>                 <resource name="ScriptRunner.java"/>
>             </by-organization>
>         </with-license>
>     </within>
> [snip...]
>
> The relevant output is here:
>
> Within the utils/src/com/cloud/utils/db directory
>     licensed under the Apache License, Version 2
> http://www.apache.org/licenses/LICENSE-2.0.txt  (as above)
>
> As you can see, there's no copyright attribution for that resource.
>
> Thanks in advance for any advice you can offer!

This issue is entirely my fault.  I was using the US spelling of organisation.

-chip

Mime
View raw message