couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joan Touzet <woh...@apache.org>
Subject Re: Upgrading to CouchDB 2.1.1
Date Tue, 07 Nov 2017 20:20:36 GMT
See my previous email, Vishesh. The release notes have been updated.

-Joan

----- Original Message -----
From: "Vishesh Mittal" <vish@platomedical.com>
To: user@couchdb.apache.org
Sent: Tuesday, 7 November, 2017 2:35:30 PM
Subject: Re: Upgrading to CouchDB 2.1.1

I am having the same error message when upgrading using the convenience
binaries on Ubuntu from 2.1.0 to 2.1.1.

I tried "sudo apt-get upgrade". Now all the databases are saying "The
database failed to load".

warm regards
Vish

On Wed, Nov 8, 2017 at 3:00 AM, Ronny Berndt <ronny@kioskkinder.com> wrote:

> Hi,
>
> i tried to upgrade from version 2.1.0 to 2.1.1.
>
> In the docs, there is only a short paragraph:
>
> ----
> 2.9.3. Upgrading
>
> Are you upgrading from CouchDB 2.0? Install CouchDB into a fresh
> directory. CouchDB’s directory layout has changed and may be confused by
> libraries present from previous releases.
> ----
>
> So far, so good.
>
> 1. I compiled the source and copy the release into a new folder.
> 2. I copied my old local.ini into the new build directory
> 3. I copied the data dir into the new build directory
>
> I started couchdb again, logged in and for all database i get the
> following message:
>
> „This database failed to load.“
>
> Clicking on "Verify CouchDB Installation“:
>
> Notification: Error: The database could not be created, the file already
> exists.
>
>
> Test                            Status
> Create Database
> Create Document ✓
> Update Document
> Delete Document ✗
> Create View             ✗
> Replication             ✗
>
> If I use an clean install (after compiling) all is fine...
>
> Am I doing something wrong?
>
> Cheers,
> Ronny




-- 
*Vishesh Mittal*
Co-founder, Plato Medical
platomedical.com
+65 9068 5643

Mime
View raw message