couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Le Brasseur <johnlebrass...@gmail.com>
Subject Build CouchDB on Windows
Date Sat, 22 Apr 2017 17:29:55 GMT
Hi.

(I am on fully up to date Windows 10)

I am trying to follow the steps on '
https://github.com/apache/couchdb-glazier'

I have got quite far with the help of Joan (Touzet).

I believe everything has worked correctly up to the point of the section

"Building CouchDB itself"

In this section I believe there is an error in file 'configure.ps1'

line 87 character 39: The comma should not be present(??? my knowledge is
limited)

If I remove the comma, the command

'powershell -ExecutionPolicy Bypass .\configure.ps1 -WithCurl'

executes seemingly correctly.

However if I run the next step:

'make -f Makefile.win check'

I get the feedback:

"'make' is not recognized as an internal or external command,
operable program or batch file."

Just to refresh, I am in an admin command window here having run the
following:

'c:\relax\bin\shell.cmd'

"Select an Erlang:
      7 for Erlang 17.5 (default)
      8 for Erlang 18.0
      1 for Erlang 18.1
Make your selection ===> 7
Select a shell:
      w for Windows prompt (default)
      b for bash prompt
      p for PowerShell prompt
Make your selection ===>
Type exit to stop relaxing."

i.e. the Windows prompt.(of the 'SDK Prompt')

Does it look like I:

a)  An error
b) Omitted something
c) Can check for the presence/absence of something that caused this.
d) I am nowhere near in the process where I should be.
e) I am misunderstanding something.


Could anyone guide me please.

I am trying to get to the point of installing geocouch on Windows.
(which looks quite difficult)

Many thanks.

John

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message