couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Lehnardt <...@apache.org>
Subject Re: CouchDB 1.6.1 on Debian 8
Date Fri, 03 Jun 2016 14:20:48 GMT

> On 03 Jun 2016, at 16:12, Sinan Gabel <sinan.gabel@gmail.com> wrote:
> 
> Hi!
> 
> I tried to install 1.x.x on Ubuntu 16.04 Desktop and it failed with roughly

What is the error precisely?

Best
Jan
--



> the same info as given above.
> 
> Br,
> Sinan
> 
> On 3 June 2016 at 05:32, Frédéric Audon <chavenay@gmail.com> wrote:
> 
>> 
>> 
>> On 1 Jun 2016, at 7:43, Jan Lehnardt wrote:
>> 
>> On 01 Jun 2016, at 00:09, Frédéric Audon <chavenay@gmail.com> wrote:
>>>> 
>>>> 
>>>> Le 31 mai 2016 à 18:59, Jan Lehnardt <jan@apache.org> a écrit :
>>>>> 
>>>>> 
>>>>> On 31 May 2016, at 18:57, Frédéric Audon <chavenay@gmail.com>
wrote:
>>>>>> 
>>>>>> 
>>>>>> Le 31 mai 2016 à 16:46, Jan Lehnardt <jan@apache.org> a écrit
:
>>>>>>> 
>>>>>>> 
>>>>>>> On 31 May 2016, at 16:06, Frédéric Audon <chavenay@gmail.com>
wrote:
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> Le 30 mai 2016 à 22:59, Jan Lehnardt <jan@apache.org>
a écrit :
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> On 30 May 2016, at 18:53, Frédéric Audon <chavenay@gmail.com>
>>>>>>>>>> wrote:
>>>>>>>>>> 
>>>>>>>>>> Hello
>>>>>>>>>> 
>>>>>>>>>> I try to install CouchDB 16.1 on Debian 8 ( jessie
)
>>>>>>>>>> 
>>>>>>>>>> I stuck
>>>>>>>>>> checking Erlang version of compatibility ... Erlang
detected
>>>>>>>>>> Version: 7.3.0 ... configure: error : The installed
version of Erlang must
>>>>>>>>>> be> = R14B ( erts - 5.8.1 ) and = <17 ( erts
-6.0 ) major_version does not
>>>>>>>>>> match
>>>>>>>>>> 
>>>>>>>>>> What should I do ?
>>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> Best option probably is to build CouchDB from source,
the 1.x.x
>>>>>>>>> branch is slightly ahead of 1.6.1 but safe to use in
production, and
>>>>>>>>> compatible with newer Erlang releases.
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>> ok
>>>>>>>> 
>>>>>>>> wget https://github.com/apache/couchdb/archive/1.6.x.zip
>>>>>>>> unzip 1.6.x.zip
>>>>>>>> cd couchdb-1.6.x/
>>>>>>>> 
>>>>>>>> How do I get ./configure ?
>>>>>>>> 
>>>>>>> 
>>>>>>> ./bootstrap
>>>>>>> 
>>>>>> 
>>>>>> Unable to find any variant: glibtoolize libtoolize
>>>>>> 
>>>>>> Have you installed a version of this package?
>>>>>> 
>>>>> 
>>>>> You need to install libtool :)
>>>>> 
>>>>> Dev dependencies are explained in DEVELOPERS (
>>>>> https://github.com/apache/couchdb/blob/1.x.x/DEVELOPERS)
>>>>> 
>>>>> (you probably want `./configure --disable-docs` to avoid the LaTeX etc.
>>>>> dependency chain)
>>>>> 
>>>>> 
>>>> Thanks Jan
>>>> 
>>>> ./bootstrap OK
>>>> ./configure --prefix=/usr/local --with-js-lib=/usr/lib
>>>> --with-js-include=/usr/include/mozjs --enable-init OK
>>>> make && make install -->KO
>>>> 
>>>> make[2]: Leaving directory '/root/couchdb-1.6.x/utils’
>>>> 
>>> 
>>> looks like you are building 1.6.x and not 1.x.x?
>>> 
>>> Can you try 1.x.x?
>>> 
>>> 
>> gzip -9 < README.rst > README.gz
>> make[2]: *** No rule to make target 'THANKS', needed by 'THANKS.gz'.  Stop.
>> make[2]: Leaving directory '/var/lib/couchdb/couchdb-1.x.x'
>> Makefile:555: recipe for target 'all-recursive' failed
>> make[1]: *** [all-recursive] Error 1
>> make[1]: Leaving directory '/var/lib/couchdb/couchdb-1.x.x'
>> Makefile:453: recipe for target 'all' failed
>> 
>> make: *** [all] Error 2
>> 

-- 
Professional Support for Apache CouchDB:
https://neighbourhood.ie/couchdb-support/


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message