couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Shorin <kxe...@gmail.com>
Subject Re: Installing CouchDB 1.6.1 on Ubuntu 14.04 - problem with erlang-abi-15.b
Date Fri, 13 Nov 2015 11:58:12 GMT
Hi,

This is Ubuntu package issues. CouchDB doesn't provides by itself any
packages for Ubuntu nor maintains them. It seems that they didn't pin
suitable Erlang release for CouchDB package.
--
,,,^..^,,,


On Fri, Nov 13, 2015 at 2:23 PM, Jim R. Wilson <wilson.jim.r@gmail.com> wrote:
> Hi CouchDB Users,
>
> This morning I struggled to install CouchDB 1.6.1 on my Ubuntu 14.04
> machine. It would complain about not being able to find the virtual package
> erlang-abi-15.b. Apparently the latest version of erlang-base (1:18.1) does
> not provide this package, on which couchdb-bin depends.
>
> My solution was to downgrade erlang to version 1:17.4 by asking aptitude
> for a second opinion as described here:
> http://askubuntu.com/questions/696930/couchdb-unmet-dependencies-couchdb-bin-1-6-1-0ubuntu5-held-broken-package
>
> I don't know if this is an Erlang problem, a CouchDB problem, or an Ubuntu
> package management problem, but I'd appreciate it if you'd forward this
> email to the correct place to get it fixed. Thanks!
>
> -- Jim R. Wilson

Mime
View raw message