couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nikolay Vlasov <>
Subject Fwd: Geocouch and CouchDB 1.6.1 comatibility
Date Mon, 06 Oct 2014 01:35:12 GMT
Hi Dave,

I followed the following instructions:

The CouchDB works ok, I'm playing around with it now.

For Geocouch I tried the following two instructions (one at a time with
recompiling both Couch and Geocouch between them):

The interesting thing is that in both cases I couldn't find the script
named './bootstrap' in the cloned project. So I had to skip this step and
start with './config'.

And no, I haven't tried it on normal Debian Wheezy. Is it non-compatible?

---------- Forwarded message ----------
From: Nikolay Vlasov <>
Date: Mon, Sep 29, 2014 at 10:05 PM
Subject: Geocouch and CouchDB 1.6.1 comatibility

Hi everyone,

I'm trying to compile Geocouch with CouchDB 1.6.1 on Raspberry Pi with
Raspbian Wheezy. The code compiled correctly, without errors but system
doesn't pass tests. I'm also trying to implement example from this
book: Getting
Started with GEO, CouchDB, and Node.js
and on the request like the following:,0,180,90

I'm getting this in the log (server freshly restarted):

[Mon, 29 Sep 2014 14:01:28 GMT] [info] [<0.32.0>] Apache CouchDB has
started on
[Mon, 29 Sep 2014 14:01:53 GMT] [info] [<0.185.0>] Opening index for db:
geoexample idx: _design/geocats sig: "76cb79e5a7640ee806c556ed29b882d5"
[Mon, 29 Sep 2014 14:01:53 GMT] [info] [<0.189.0>] Starting index update
for db: geoexample idx: _design/geocats
[Mon, 29 Sep 2014 14:01:54 GMT] [error] [emulator] Error in process
<0.195.0> with exit value:

[Mon, 29 Sep 2014 14:01:54 GMT] [error] [<0.117.0>] {error_report,<0.31.0>,


Any ideas on what's wrong?

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message