couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arnaud Delobelle <Arnaud.Delobe...@sparx.co.uk>
Subject Building couchdb 1.6 on Debian Wheezy
Date Mon, 30 Jun 2014 15:12:50 GMT
Hi there,

I’ve built couchdb on Wheezy today and I hit a problem which I found tricky to understand.
In the docs [1] it makes a list of prerequisites, among which is

    sudo apt-get install libmozjs-dev

Unfortunately running ./configure with this installed fails with an unhelpful message (IIRC,
something like "jsapi.h found but can’t be compiled, please file a JIRA ticket”).

In fact it turns out that the correct dependency is

    libmozjs185-dev

I only found out when reading the output of  `./configure —help`, which mentions:

  --enable-js-trunk       allow use of SpiderMonkey versions newer than
                          js185-1.0.0

Note that adding this option with libmozjs-dev installed still gives the same error message.
I guess it would be useful to update the docs [1] for other who may want to build it.

Having overcome this, building and installing was a very satisfying

    ./configure && make && make install

(please reply to me as well as the list I’m not subscribing to the list)

Cheers,

Arnaud Delobelle

[1] http://docs.couchdb.org/en/latest/install/unix.html


Mime
View raw message