couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Omer Yousaf <omer.you...@northbaysolutions.net>
Subject Installing CouchDB from Source: Problem Installing SpiderMonkey1.8.5
Date Thu, 17 Apr 2014 14:21:11 GMT
Hi,
In installing CouchDB from source I am stuck at the installing
SpiderMonkey1.8.5 step. In order to run the ./configure command for couchdb
I must specify paths "--with-js-lib" and "--with-js-include" but failing to
install SpiderMonkey prevents me from doing so. I have tried to install
spidermonkey by doing following steps:
1) unpack js185-1.0.0.tar.gz and libmozjs185-devel-1.0.0-3.tar.bz2 packages
2) cd to js-1.8.5\js\src folder
3) run the command: ./configure
    or:  ./configure
--with-js-lib=/cygdrive/c/cygwin/home/omer.yousaf/src/js-1.8.5/js/src/usr/lib

--with-js-include=/cygdrive/c/cygwin/home/omer.yousaf/src/js-1.8.5/js/src/usr/include
I get the error "configure: error: installation or configuration problem:
C++ compiler cannot create executables".
Can you guide me as to how to get spidermonkey installed. Just FYI, I am
using this page for instructions on how to build couchdb from source
https://github.com/apache/couchdb/blob/master/INSTALL.Windows.
Best Regards,
Omer Yousaf
NorthBay Solutions, Lahore

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message