couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Cottlehuber <...@jsonified.com>
Subject Re: crash when attempting to create a view, 1.5.0
Date Mon, 17 Mar 2014 11:14:45 GMT
On 17. März 2014 at 09:12:02, Nat Lownes (nat.lownes@gmail.com) wrote:
> This is happening on a database with about 360k documents. I consistently
> get this crash when attempting to create any design documents or temporary
> views. I came across it first using python and javascript clients, tried
> thru curl and the UI at /_utils/ all with the same result. Below is my
> attempt at creating a view that just emits ids.
>  
> Screen shot of the UI:
> https://www.dropbox.com/s/1wdglxg19sk2sor/Screenshot%202014-03-16%2018.09.24.png  
>  
> log output
>  
> ** Reason for termination ==
> ** {badmatch,{error,enosys}}

Hi Nat,

ENOSYS is trying to use a function call that is not available on your system.

Could be something like you are running erlang with kernel polling enabled, but your kernel
doesn’t support that.

try `erl +K true` and see what happens. If it fails, remove +K from your `couchdb` script.

Other than that, usual questions:

- what OS/distro are you using
- how was couchdb built/installed?
- did it ever work before?
etc

A+
Dave



Mime
View raw message