couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Weber <>
Subject Re: Cannot get os_daemon api to function
Date Mon, 03 Feb 2014 14:17:01 GMT
Yup. That worked.

I am trying to pass a JSON object because that is what the doc says.
"The process started" is not a valid JSON object, although the doc says that $MESG is any
JSON object.  It does not say that $MESG is only a non-JSON string.

Anyway, live and learn.

 From: Alexander Shorin <>
To: "" <> 
Sent: Monday, February 3, 2014 8:06 AM
Subject: Re: Cannot get os_daemon api to function

On Mon, Feb 3, 2014 at 5:52 PM, Scott Weber <> wrote:
> Now I get an 'Invalid Log Message' when I try to log.  My log message is exactly:
> ["log",{"log" : "The process started"}]

Have you tried to pass just "The process started" string without
object wrapper? I wonder why you trying to do this, since there is no
much reasons for it.

> There’s also an API for adding messages to CouchDB’s logs. Its simply:
> ["log", $MESG]\n
> Where $MESG is any arbitrary JSON. There is no response from this command. As
> with the config API, the trailing \n represents a newline byte

Probably "any arbitrary JSON" is too greedy definition since the only
acceptable JSON try is a string one.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message