couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Gable <ziggythehams...@gmail.com>
Subject RE: CouchDb startup error: Failure to start Mochiweb
Date Sat, 09 Nov 2013 23:11:09 GMT
There should be an init script. Try:
service couchdb start

If that doesn't work:
sudo su -u couchdb couchdb From: Alexander Gabriel
Sent: 11/9/2013 15:27
To: user@couchdb.apache.org
Subject: CouchDb startup error: Failure to start Mochiweb
Hi experts

I've installed a droplet at digitaloceans.com using ubuntu 13.10, because
it is easy to install couchdb 1.4 on it as it's included in the software
repository.

So I ran "sudo apt-get install couchdb -y" and as far as I remember there
were no errors.

But when I run "sudo -i -u couchdb couchdb" I get the error mentioned here:
http://wiki.apache.org/couchdb/Error_messages#Unavailable_Port. The page
says: "Edit your /etc/couchdb/couch.ini file and change the Port setting to
an available port"

When I run "nmap -v www.arteigenschaften.ch" I get only one open port:
22/tcp (service: ssh) and 999 closed ports.

I'm a bit surprised that port 90 isn't open. But maybe that is because
nobody is listening yet?

If I understand correctly the fact that port 5984 isn't open also means
that no one is listening. But then why should I change to an available port
when the problem is not the port but the listener? Would "not available"
mean that someone else is already listening? But then the fact that port
5984 is not "open" would mean that the problem isn't in the port but
somewhere else.

"ufw status" > "inactive". So no firewall blocking (not sure if this would
be relevant for connecting to localhost)

"sudo iptables -A INPUT -p tcp --dport 5984 -j ACCEPT" didn't help

I guess now is the time to mention that I'm a linux and ip noob. Surely
there's something glaringly obvious that I'm unaware of?

In case it's any help: www.barbalex.ch/downloads/erl_crash.dump

Alex

Mime
View raw message