couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Newson <rnew...@apache.org>
Subject Re: named reduce function
Date Tue, 16 Jul 2013 23:19:38 GMT
:)

On 17 July 2013 00:14, Stanley Iriele <siriele2x3@gmail.com> wrote:
> That sounds painful.... Thanks... I was just curious is all. Man Robert
> you're really on top of these user issues... Someone should send you a
> trophy of kind.... Maybe just a big red couch!
>
> On Jul 16, 2013 4:08 PM, "Robert Newson" <rnewson@apache.org> wrote:
>>
>> Because reduce values are calculated at view build time, not query
>> time, so you're basically asking the view to precompute every possible
>> function's output.
>>
>> B.
>>
>>
>> On 17 July 2013 00:01, Stanley Iriele <siriele@breaktimestudios.com>
> wrote:
>> > just curious,
>> >
>> > How feasable is it for there to be named reduce functions
>> > and instead of reduce=true/false it could be reduce=<function name>
>> > and keep everything like group levels the same. and the default for no
>> > reduce being specified it could default to nothing ..like false. the
> only
>> > Illegal name for a reduce function could be 'map'.
>> >
>> > right now I am just returning an object much like what _stats
> generates. I
>> > was just curious why or why not this was a good sounding idea

Mime
View raw message