couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dilpreet singh <giggs...@gmail.com>
Subject Re: Couchdb Server Error 500
Date Wed, 19 Jun 2013 03:28:06 GMT
the couchdb server log entry is like this :

[Tue, 18 Jun 2013 19:29:30 GMT] [error] [<0.29253.0>] Uncaught server
error: {error,all_dbs_active}
 43935 [Tue, 18 Jun 2013 19:29:30 GMT] [info] [<0.29253.0>] 127.0.0.1 - -
HEAD /db-2013-3-20 500

Is there a way to resolve this error . To work with with couchdb again , i
have to restart it which is not the correct way as i have to start querying
process all over again .

Thanks in advance


On Mon, Jun 17, 2013 at 5:51 PM, svilen <az@svilendobrev.com> wrote:

> check couchdb logs to see eventualy what exact request caused it
>
>
> On Mon, 17 Jun 2013 17:46:35 -0400
> dilpreet singh <giggs102@gmail.com> wrote:
>
> > Hi
> >
> > I have aroung 180 databases in the couchdb , each of about 3Gb . I am
> > using the permanent views to run some queries in all the databases
> > one by one . Also i am using python-couchdb to access couchdb using
> > python . I get the following error after going through few databases :
> >
> >  db = server[dbname]
> >   File
> >
> "/usr/local/lib/python2.7/dist-packages/CouchDB-0.8-py2.7.egg/couchdb/client.py",
> > line 137, in __getitem__
> >     db.resource.head() # actually make a request to the database
> >   File
> >
> "/usr/local/lib/python2.7/dist-packages/CouchDB-0.8-py2.7.egg/couchdb/http.py",
> > line 377, in head
> >     return self._request('HEAD', path, headers=headers, **params)
> >   File
> >
> "/usr/local/lib/python2.7/dist-packages/CouchDB-0.8-py2.7.egg/couchdb/http.py",
> > line 419, in _request
> >     credentials=self.credentials)
> >   File
> >
> "/usr/local/lib/python2.7/dist-packages/CouchDB-0.8-py2.7.egg/couchdb/http.py",
> > line 310, in request
> >     raise ServerError((status, error))
> > couchdb.http.ServerError: (500, '')
> >
> >
> > I googled it and found it to be some couchdb issue . Can someone
> > please tell me if there is any workaround to solve this error . Any
> > advice would be appreciated.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message