couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Cottlehuber <...@jsonified.com>
Subject Re: Intermittent 401 errors during replication
Date Sat, 30 Mar 2013 21:54:31 GMT
On 28 March 2013 16:16, Bill <bill.foshay@noteandgo.com> wrote:
> I'm having an issue with a continuous filtered pull replication pulling from my
> server side db to my mobile app. For some reason, I'm getting intermittent 401
> errors after the replication begins. These errors cause TouchDB to prematurely
> stop replicating because it thinks there's an authentication problem. Before
> stopping though, the app does successfully pull a number of documents which is
> strange. I would think if there were an authentication issue, it wouldn't be
> able to pull any. I've encountered this problem both with a database hosted on
> IrisCouch, and an instance I have running locally. The fact that I get the
> errors with both instances makes me wonder if there's something wrong with my
> couchdb setup. I have a server admin user set up on IrisCouch and locally. And
> I've set up both admins and members on the databases themselves. I currently
> have require_valid_user = false in the couchdb config but I still get the 401s.
> Is there anything else anyone can think of to help me fix or debug this? I
> really appreciate any help!
>
> Thanks,
> Bill

Hi Bill,

perhaps you can change [log] level = debug in your local.ini file, and
capture some info about what happens? If you're really keen, running
`ngrep port 5984` and using something like charles proxy or wireshark
to peer into the wire data is pretty handy.

A+
Dave

Mime
View raw message