couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Accoun <>
Subject Re: compilation_error Expression does not eval to a function
Date Mon, 28 Jan 2013 09:43:44 GMT
Here's some more input:

I tried to compile from source on my workstation which also runs debian

It appears that the spidermonkey version present in debian is too new.

configure: error: Your SpiderMonkey library is too new.

NOTE: Check above for an error about NSPR

Versions of SpiderMonkey after the js185-1.0.0 release remove the optional
enforcement of preventing anonymous functions in a statement context. This
will most likely break your existing JavaScript code as well as render all
example code invalid.

If you wish to ignore this error pass --enable-js-trunk to ./configure.

I'm afraid ignoring this error as suggested by the configure script, will
force me to change all my views.

ATM I don't have any available environment to compile couchdb. Are there
any binaries that I can just download and run?

Alternatively, I could use some help compiling couchdb with all the
dependencies in the right version.

On Mon, Jan 28, 2013 at 10:11 AM, John Accoun <> wrote:

> This morning I started to get an error in one of my views.
> ---
> Error: compilation_error
> Expression does not eval to a function. ((new String("undefined")))
> ---
> I thought this was very strange since I don't remember changing that view.
> I googled a bit but to no avail. Also tried to edit the view, first by
> pushing my design document with erica, then through futon.
> I changed it a little bit, the group indexing process kicked in and I
> could see the view output on futon. Right after, I clicked 'Overview >
> my_database' ob futton, and, I got a dialog box on my browser (Crhomium)
> with that same error. from this point on, every view throws that same error.
> My couchdb  instance runs on a VM with debian:
> ---
> # lsb_release -a
> No LSB modules are available.
>  Distributor ID: Debian
> Description: Debian GNU/Linux 6.0.5 (squeeze)
>  Release: 6.0.5
> Codename: squeeze
> ---
> What could be causing this issue? How can I fix it?

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message