couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Accoun <json...@gmail.com>
Subject compilation_error Expression does not eval to a function
Date Mon, 28 Jan 2013 09:11:53 GMT
This morning I started to get an error in one of my views.

---
Error: compilation_error
Expression does not eval to a function. ((new String("undefined")))
---

I thought this was very strange since I don't remember changing that view.
I googled a bit but to no avail. Also tried to edit the view, first by
pushing my design document with erica, then through futon.
I changed it a little bit, the group indexing process kicked in and I could
see the view output on futon. Right after, I clicked 'Overview >
my_database' ob futton, and, I got a dialog box on my browser (Crhomium)
with that same error. from this point on, every view throws that same error.


My couchdb  instance runs on a VM with debian:

---
# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 6.0.5 (squeeze)
Release: 6.0.5
Codename: squeeze
---

What could be causing this issue? How can I fix it?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message