couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donal Simmie <donal.sim...@gmail.com>
Subject Re: View creation error on specific DB
Date Mon, 21 Jan 2013 16:27:35 GMT
As an update I have tried numerous approaches to attempt to fix/workaround
this problem:

1. Compacting the database.
2. Replicating to a local copy of the DB and retrying view creation.
3. Dumping DB contents to JSON with dump.py and loading into another DB
with load.py

None of these worked.

After downloading the couchdb-python library I added the python view server
to Futon and ran view code in python and this does fix the problem.

So if the problem is with the javascript view server, does this help in
identifying what the issue might be and how I could fix it?

E.g.

Bad entry in config file,
Corrupt document(s),
Something else??

Thanks





On Thu, Jan 17, 2013 at 2:59 PM, Donal Simmie <donal.simmie@gmail.com>wrote:

> I am getting an os error on view creation for a certain database. All my
> views for other databases are working but I cannot create any on this one
> without it failing.
>
> The error message is: os_process_error,{exit_status,0}}
>
> I was trying a proper view but even this basic one is broken:
>
> function(doc) {
>   emit(1, doc);
> }
>
> Note:
> I have been using Futon for view creation.
> The all documents view is fine and documents themselves can be viewed.
> I altered the default configuration file by adding a compactions section
> with the following key/value pair: -default: [{db_fragmentation, "70%"},
> {view_fragmentation, "60%"}, {from, "23:00"}, {to, "04:00"}].
> The DB in question contains 3.6 GB of data.
>
> Version: 1.2
> Os: Mac OS X 10.8.2
>
> The trace in the log file is available here: http://pastebin.com/AdrJ6jeB
>
> Any suggestions please?
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message