couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wendall Cada <wenda...@83864.com>
Subject Re: CouchDB 1.2.0, Amazon EC@ & Amazon Linux AMI
Date Sat, 01 Sep 2012 21:52:28 GMT
I created an rpm spec for 1.2.0 and instructions for building 
spidermonkey 1.8.5 https://github.com/wendall911/couchdb-rpm. We 
currently use this in production on Amazon Linux. Build the rpms. Update 
spidermonkey. Install couchdb. Done.

Wendall

On 09/01/2012 05:14 AM, Martin Hewitt wrote:
> Hi all,
>
> Just wondering if anyone has a successful build script/process for CouchDB 1.2.0 on an
Amazon EC2 Linux AMI instance?
>
> It seems to be similar to CentOS, but my usual, hardened, CentOS deployment process isn't
working - when I come to make CouchDB, I get the dreaded "couchdb implicit declaration of
function ‘INT_FITS_IN_JSVAL’" error and it bails out.
>
> The only difference I'm finding so far is that, in order to compile SpiderMonkey, I'm
having to download an .rpm for autoconf-2.13 as the Amazon yum repos don't seem to have it,
where the CentOS repos do.
>
> However, all the steps complete satisfactorily, and SpiderMonkey compiles, but by the
time I get to make-ing CouchDB, I get the above error.
>
> In pseudo-script, my process is:
>
> * Add RPMForge repo
> * Install dependencies: libicu-devel openssl-devel make gcc js-devel libtool which ncurses-devel
icu libicu
> * Install ERLang
> * Install SpiderMonkey deps
> * Download SpiderMonkey source
> * autoconf-2.13/configure/make && make install
> * Download CouchDB source
> * configure/make && make install
>
> ...which is roughly where I get stuck.
>
> Any advice would be hugely appreciated.
>
> Thanks,
>
> Martin


Mime
View raw message