couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Tisdall <>
Subject Re: couchdb returning empty response
Date Thu, 16 Aug 2012 20:18:37 GMT
Sorry, forgot to mention earlier that I'm running Debian 6.0.  I'm not
sure the arch. as it's a virtualized server...  /proc/cpuinfo says
"Intel(R) Xeon(R) CPU           E5520"

Yes, I've had issues before with running out of resources because the
virtualized instance is rather small.  Usually that results in the
whole machine crashing, though.  When couchdb goes down, there is
still available swap space and lots of HD space (I need lots of empty
space to do compaction on the db).  Also, couchdb is able to restart
with no issues.  ... I just tried looking through system logs for any
kind of resource issue and couldn't find anything.


On Thu, Aug 16, 2012 at 4:07 PM, Dave Cottlehuber <> wrote:
> On 16 August 2012 21:44, Dave Cottlehuber <> wrote:
>> On 16 August 2012 17:16, Tim Tisdall <> wrote:
>>> I tried running my code again and got a bunch of these entries in my logs:
>>> [Thu, 16 Aug 2012 14:53:03 GMT] [error] [<0.20.0>] {error_report,<0.9.0>,
>>>                                  {<0.20.0>,std_error,
>>>                                   "File operation error: eacces.
>>> Target: ./mochiweb_response.beam. Function: get_file. Process:
>>> code_server."}}
>>> here's the file listing for the file (as you can see it's readable by all):
>>> -rw-r--r-- 1 root staff 1420 Aug  7 21:11
>>> /usr/local/lib/couchdb/erlang/lib/mochiweb-1.4.1/ebin/mochiweb_response.beam
>> As you noticed, this is file permissions related. So check all of
>> those, esp permissions on the couchdb .beam files.
>> If you're logged in as that user, does pushd
>> /usr/local/lib/couchdb/erlang/lib/mochiweb-1.4.1/ebin && cat
>> mochiweb_response.beam > /dev/null work?
>> I usually do an
>>     $ sudo -u couchdb couchdb -i
>> to start couchdb in interactive mode before switching to daemon usage.
>> Maybe a recursive chmod / chown on/usr/local/lib/couchdb is in order?
>> If you let me know what arch/platform this is on, I'll check tomorrow
>> on a fresh install if that doesn't fix it, using your notes provided.
>> A+
>> Dave
> Having said all that, I don't see how couch could start with these
> permissions, certainly not to the point of doing a bulk upload. So we
> must be running out of some resource. Are you able to provide the json
> privately to us for a look?
> A+
> Dave

View raw message