couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Torres <>
Subject Re: geocouch with polygons
Date Thu, 12 Jul 2012 06:32:20 GMT
Thank you Volker. I am interested in getting this to work.

I'll have to get back to you still later. I thought I was having
problems with geocouch (with support for polygons) in combination with
couchdb 1.2.0 but it turns out I'm having problems with couchdb 1.2.0
itself. Maybe I can get advice on this new issue from someone?

1.2.0 builds fine, make check passes all tests, the configure script
is happy, and
I removed the first installation (I used make uninstall to do some of
that as well).
I manually removed the old geocouch.ini file. After the new install I
changed the
ownership and groups to my couchdb user and group, etc. And I am not
forgetting to
use Firefox.

But some of the futon tests are failing...and then many of them fail.
To be precise, the attachments test fails right away with:
Assertion failed: xhr.responseText == lorem
Exception raised: {}

list_views fails right away with:
Assertion 'xhr.status == 200, "standard get should be 200"' failed:
standard get should be 200
Assertion failed: /head0123456789tail/.test(xhr.responseText)

rev_stemming fails right away with:
Assertion failed:"bar", {revs: true})._revisions.ids.length
== newLimit + 1
Assertion failed:"bar", {revs: true})._revisions.ids.length
== newLimit + 1

view_compaction fails [but succeeds on a 2nd manual try] with:
Assertion failed: resp.view_index.disk_size < disk_size_before_compact

Then if I run all the tests again, a whole lot more of them fail. In particular
all tests after users_db_security fail with the error:
Exception raised: {"error":"unauthorized","reason":"You are not a
server admin."}
The test users_db_security itself fails with: Exception raised: {}

And following any links--or clicking on reload--causes the "admin party" to
suddenly end and I'm no longer admin nor can I run any more tests. The "Verify
 your installation" works the first time (before all these failed tests) but
after the failures, it returns X: [object Object]

I'm not sure what to do. I have a nagging feeling something from the
1.1.0 install
lingers and screws up the 1.2.0 install, but I cannot find it. And if it is not
that I don't have a clue right now what is causing this error. I've never had
this much trouble building from source before and it's eaten up so much time.


On Wed, Jul 11, 2012 at 11:19 AM, Volker Mische <> wrote:
> Hi Paul
> On 07/11/2012 03:44 AM, Paul Torres wrote:
>> Does anyone have any experience with the latest experimental geocouch
>> that supports
>> polygons? From:
> Yes ;)
>> Being experimental, does that mean the tests in the futon test suite do not
>> neccessarily all pass? I have a few that are failing, but I cannot track down
>> any (more) of my own errors that might be causing it. I have all the
>> dependencies
>> including GEOS available in my PATH, and my ERL_FLAGS are set, etc. I
>> compiled and copied the .ini file and the tests and updated the list
>> of tests that
>> should be run... I'm running couch 1.1.0 compiled from source.
> All Futon tests should work. The problem might be that this version is
> for CouchDB 1.2.0 and was only tested with it.
>> Poking around the makefile for the geocouch I noticed it included targets for
>> running tests and these do not all pass either, so it would seem to me that
>> something might be wrong at the compilation stage. If true then I guess the
>> code just needs more work. But is that the case? I'm not very fluent in Erlang
>> yet to read it all and determine definitely for myself and I'd like to
>> double check
>> with anyone who knows for certain.
> Try again with CouchDB 1.2.0 and let me know if it still doesn't pass
> all tests.
> Cheers,
>   Volker

View raw message