couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Duffield <tom.duffi...@gmail.com>
Subject Re: _replicate error
Date Sat, 14 Jul 2012 22:52:17 GMT
When I run the curl command (both with and without user/password), this is
all that shows up in the logs:

Apache CouchDB 1.2.0 (LogLevel=DEBUG) is starting.
Apache CouchDB has started. Time to relax.
....
[error] [<0.140.0>] Uncaught error in HTTP request: {error,undef}
[error] [<0.140.0>] Uncaught server error: undef
....

Like I said, very unhelpful.

On Sat, Jul 14, 2012 at 5:36 PM, Dave Cottlehuber <dave@muse.net.nz> wrote:

> On 14 July 2012 22:46, Tom Duffield <tom.duffield@gmail.com> wrote:
> > Here is the sanitized command that I ran :
> > curl -H 'Content-Type: application/json' -X POST
> > http://localhost:5984/_replicate -d '{"source":
> > "http://<USER>:<PASS>@<EXTERNAL_DBASE>/<DBASE>",
> > "target": "http://localhost:5984/<DBASE>"}'
> >
> >
> > I can run _all_dbs and do POST and GET commands against both databases
> just
> > fine. I've also tried multiple external databases.
> >
> > I will mention that all the external databases are running 1.1.0 while my
> > local database is running 1.2.0.
> >
> > Thanks,
> > Tom
>
> Hey Tom,
>
> Can you friendpaste the logs somewhere? Perhaps we might see something
> that looks more significant to us :-)
>
> 2ndly, does replication work for you if you omit the admin:passwd
> part? I am wondering if your password needs different encoding etc.
>
> A+
> Dave
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message