couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lee Burke <lbu...@aseg.com>
Subject Re: trouble accessing futon
Date Tue, 10 Jul 2012 14:44:42 GMT
Martin,

You hit it right on, it was iptables. I didn't realize CentOS had iptables running by default.
For any others with this issue, I ran these commands:
service iptables stop
service ip6tables stop.

Now that I can access futon, I'll start seeing how this software works.

Thanks.
Lee 

----- Original Message -----
From: "Martin Hewitt" <martin@thenoi.se>
To: user@couchdb.apache.org
Sent: Monday, July 9, 2012 4:34:54 PM
Subject: Re: trouble accessing futon

In my experience, that sounds like one of two things: 

1. bind_address in local.ini/default.ini being set to 127.0.0.1 instead of 0.0.0.0
2. iptables or similar blocking inbound connections

If you've discounted [2], have you tried [1]? 

Martin


On Monday, 9 July 2012 at 23:52, Lee Burke wrote:

> Hello,
> I'm new to couchdb and have my first installation on CentOS 6 and couchdb 1.0.3, installed
using yum.
> Using my Win7 PC and Firefox, I try to access http://hostname:5984/ or http://hostname:5984/_utils.
Neither will respond, Firefox times out with this message: The connection has timed out. The
server at hostname is taking too long to respond.
> On the server, I can run curl http://hostname:5984 and get the "couchdb":"Welcome" response
and also curl -X GET http://hostname:5984/_all_dbs and get the "_users" response.
> On my PC, I've disabled the firewall, but still no luck.
> 
> Any suggestions?
> Thanks.
> 
> Lee 


-- 
Lee Burke

ASEG Inc.
System Administrator
858-550-0500 x-320

Mime
View raw message