couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CGS <cgsmcml...@gmail.com>
Subject Re: Error upgrading from 1.1 to 1.2
Date Tue, 19 Jun 2012 13:47:10 GMT
It may be a problem in your Erlang installation. To test that, please,
start an Erlang shell like this (in BASH):

ERLPA=$(ERLEBIN="/usr/lib/erlang/lib/" && for var in $(ls ${ERLEBIN}) ; do
echo -n " ${ERLEBIN}/${var}/ebin" ; done) && erl -pa ${ERLPA} -init_debug

and try to start again sasl and os_mon:

application:start(sasl).
application:start(os_mon).

CGS


On Tue, Jun 19, 2012 at 3:24 PM, Juan José Sánchez Mesa <
juanjo.listas@doblej.net> wrote:

> With the 'application:start(os_mon).' command I got same error:
>
>
> {error,{"no such file or directory","os_mon.app"}}
>
>
> os_mon.app file is located at:
> /usr/lib/erlang/lib/os_mon-2.**2.4/ebin/os_mon.app
>
>
> What can I do ?
>
> Thanks!
>
> El 19/06/2012 15:12, CGS escribió:
>
>> Hi Juan,
>>
>> Could you provide the output of the followings:
>> 1. start an Erlang shell in the debug mode (erl -init_debug);
>> 2. copy and paste:
>>
>> application:start(sasl).
>> application:start(os_mon).
>>
>> You should get something like I attached here if everything goes well.
>>
>> CGS
>>
>>
>>
>>
>>
>> On Tue, Jun 19, 2012 at 2:32 PM, Juan José Sánchez Mesa
>> <juanjo.listas@doblej.net <mailto:juanjo.listas@doblej.**net<juanjo.listas@doblej.net>>>
>> wrote:
>>
>>    Hi!
>>
>>    I'm new to the list.
>>
>>    I was using CouchDB 1.10 on Ubuntu 10.04 and was working pretty well.
>>
>>    Now, I've upgraded to 1.20 using sources, and now, CouchDB don't
>>    start with this error:
>>
>>    {"init terminating in do_boot",{{badmatch,{error,{"_**_no such file or
>>    directory","os_mon.app"}}},[{_**_couch,start,0},{init,start_**
>> it,__1},{init,start_em,1}]}}
>>
>>    init terminating in do_boot ()
>>
>>
>>    This error suggests that erlang-os-mon package is not installed.
>>    But, it's already installed.
>>
>>    I've tried to delete files in /usr/local/lib/couchdb/erlang/**__lib
>>    has suggested in
>>    http://wiki.apache.org/__**couchdb/Installing_on_Ubuntu<http://wiki.apache.org/__couchdb/Installing_on_Ubuntu>
>>
>>    <http://wiki.apache.org/**couchdb/Installing_on_Ubuntu<http://wiki.apache.org/couchdb/Installing_on_Ubuntu>>
>> and do 'make
>>    install' but still not working.
>>
>>    Version 1.10 was working perfect.
>>
>>    Any idea ?
>>
>>    Thanks!
>>
>>
>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message