couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CGS <cgsmcml...@gmail.com>
Subject Re: init terminating in do_boot
Date Thu, 31 May 2012 21:19:51 GMT
Hi Dave,

Thank you for your reply. Indeed, downgrading Erlang version didn't help,
but your suggestion helped me in finding the error. It was a path problem
(more precisely, /usr/local/lib which wasn't in LD_LIBRARY_PATH by default
under CentOS 5.8, and I had libicui18n.so.49 there). I am surprised it
didn't show the problem during running the configure script or while
compiling CouchDB, but I suppose it was added by hand in the script
searching paths. Now, CouchDB is purring like a cat. Thanks a lot from
another happy CouchDB user!

Cheers,
George




On Thu, May 31, 2012 at 10:05 PM, Dave Cottlehuber <dave@muse.net.nz> wrote:

> On 31 May 2012 18:39, CGS <cgsmcmlxxv@gmail.com> wrote:
> > I haven't attached any COUCHDB_USER variable to my BASH session (unless
> the
> > couchdb script adds it, but I see no COUCHDB_USER in that script). So, no
> > 'su'ing away from root.
> >
> > Is there any known problem in between CouchDB and Erlang/OTP R15B01? Any
> > idea, downgrading Erlang version would do any good?
>
> No.
>
> You might get something useful by starting 'erl -init_debug' & then to
> start up
> erlang solo (not as couch) and then progressively start up dependent apps:
>
>    erl -init_debug  -env ERL_LIBS
> /usr/local/Cellar/couchdb/1.2.0/lib/couchdb/erlang/lib -couch_ini
>
> and then:
>
>    application:load(crypto), application:start(crypto).
>    application:load(couch), application:start(couch).
>
> output should resemble this (from my mac):
>
> https://friendpaste.com/6zett3aAHSafRNZbgfMBoD
>
> A+
> Dave
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message