couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Petter Olofsson <petter.olofs...@screeninteraction.com>
Subject Authorization failures after creating user accounts in Futon
Date Thu, 12 Apr 2012 17:51:38 GMT
Hi,

The problem was that the user accounts that I created using Futon did not
work. The user account did not function after waiting a while either and
trying again.

This is from the couch.log when I created a user account using futon:
[Thu, 12 Apr 2012 14:22:57 GMT] [info] [<0.1392.0>] <ip> - - 'PUT'
/_users/org.couchdb.user%3Apetter 201
[Thu, 12 Apr 2012 14:22:57 GMT] [info] [<0.1393.0>] <ip> - - 'POST'
/_session 401

I tried restarting the server and database a bunch of times, without
success and still it was impossible to login.

Since the log-event are quite poor I changed the log-level to debug in
local.ini to get more info and restarted couchdb.

After this change the login and sign-up process in futon worked fine, and
the already created user account worked fine. Even after changing back to
log level to info the server continued to work fine.

Have anyone experience a problem similar to this one?

Any feedback from someone with similar problems and/or has a theory on what
the underlaying problem could be.

Im running:
Apache CouchDB 1.0.1 on Ubuntu 10.04.2 LTS.

BRs,
Petter
-- 
Petter Olofsson

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message