couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Kimber <>
Subject RE: Couchdb 1.2 installed on Centos 5.8 starts with File operation error and Test Suite fails
Date Thu, 19 Apr 2012 15:40:55 GMT
Yep i've read and applied that and I still get the error when I run the test suite.



-----Original Message-----
From: Robert Newson [] 
Sent: 19 April 2012 16:28
Subject: Re: Couchdb 1.2 installed on Centos 5.8 starts with File operation error and Test
Suite fails

Hi Mike,

The INSTALL.Unix file lists all the settings you need, and couchdb
does need write access to its configuration files. Adjust paths to
match your installation root.

    chown -R couchdb:couchdb /usr/local/etc/couchdb
    chown -R couchdb:couchdb /usr/local/var/lib/couchdb
    chown -R couchdb:couchdb /usr/local/var/log/couchdb
    chown -R couchdb:couchdb /usr/local/var/run/couchdb

    chmod 0770 /usr/local/etc/couchdb
    chmod 0770 /usr/local/var/lib/couchdb
    chmod 0770 /usr/local/var/log/couchdb
    chmod 0770 /usr/local/var/run/couchdb


On 19 April 2012 16:18, Mike Kimber <> wrote:
> Dave,
> Thanks for following up.
> I checked the permissions you listed and they match my couchdb 1.1.1 install, however
on both systems files under /etc/couchdb are owned by root, but are read accessible by everyone
and from the looks of them don't need to be writable by the couchdb user, unless that changed
in 1.2.0?
> If I run ./configure without --with-js-trunk I get:
>> checking whether JSOPTION_ANONFUNFIX is declared... no
>> configure: error: Your SpiderMonkey library is too new.
>> NOTE: Check above for an error about NSPR
>> Versions of SpiderMonkey after the js185-1.0.0 release remove the optional
>> enforcement of preventing anonymous functions in a statement context. This
>> will most likely break your existing JavaScript code as well as render all
>> example code invalid.
>> If you wish to ignore this error pass --enable-js-trunk to ./configure.
> I got this on 1.1.1 also.
> With regard to Centos ISO, that's one of the issues, I have no issue with Couchdb 1.2
on the Centos 5.8 images I built myself from ISO, but the ones I have an issue with are on
a hosted Virtualisation environment and provided to me so all I can provide is:
> [kana@KCEngCI200 apache-couchdb-1.2.0]$ uname -a
> Linux KCEngCI200 #1 SMP Wed Feb 3 11:28:48 PST 2010 x86_64 x86_64 x86_64
> [kana@KCEngCI200 apache-couchdb-1.2.0]$ cat /etc/redhat-release
> CentOS release 5.8 (Final)
> [kana@KCEngCI200 apache-couchdb-1.2.0]$
> I get them as Centos 5.3 images and then have to apply the Centos 5.8 updates myself
(don't ask!).
> Mike
> -----Original Message-----
> From: Dave Cottlehuber []
> Sent: 18 April 2012 19:06
> To:
> Subject: Re: Couchdb 1.2 installed on Centos 5.8 starts with File operation error and
Test Suite fails
>> On Tue, Apr 17, 2012 at 10:28 AM, Mike Kimber <> wrote:
>>> Ok, I've taken a different approach and now I have a working set of
>>> Couchdb test.
>>> Basically I installed Couchdb 1.1.1 and confirmed that it was working
>>> correctly. Then I downloaded Couch 1.2 and installed that over the top of
>>> my Couchdb 1.2. I then ran the tests and they are now working.
>>> Two possibilities for the original issue seem to me:
>>> 1. It's a permissions issue as GCS suggest and the way I install 1.1.1
>>> sets these correctly, but for the like of me I cant spot what they are!
> My checklist is:
> couch user has r/w to the equivalent of:
> /var/lib/couchdb
> /var/log/couchdb
> /var/run/couchdb
> /etc/couchdb
> & obviously read to the binaries as well. The Mac install notes
>>> 2. This approach does not change curl, Erl, etc and there some issue with
>>> the later versions of these on Centos 5.8
>>> This approach suits my end goal i.e. I'm trying to upgrade anyway, so I'll
>>> probably never get to the bottom of it.
>>> GCS thanks for the help.
>>> Mike
> Hi Mike,
> I'd rather we find a way to help you through this, the above approach is sure
> to crap out on you in future in some subtle but critical fashion.
> My guess is that your configure is really building against a different
> spidermonkey
> than what you are actually expecting.
> Can you post the output from below, & resulting config.log somewhere?
>    ./configure --with-erlang=/usr/local/lib/erlang/erts-5.7.5/include
> NB the --with-js-trunk shouldn't be used unless you know what you are doing, it
> bypasses the checks that the js you are building against is actually compatible
> with couchdb.
> If you point me to a suitable ISO I'll whip up a centos and take a look also.
> A+
> Dave

View raw message