couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Smith <...@iriscouch.com>
Subject Re: replication to iriscouch fails
Date Tue, 06 Mar 2012 01:02:09 GMT
Hi, Alex. I looked at your Iris Couch logs, dating back to February.

Just to clarify: the illegal name error is on your local couch. There
are no such errors, nor are there any 400s or 500s either.

I wonder if maybe you have special characters in your username or
password for the remote db? For example, a ":" or an "@" might trigger
a parsing bug in CouchDB? If so maybe you could escape
(encodeURIComponent) them?

(I have converted all of my passwords to hexadecimal checksums of the
real strings, to avoid this issue. But I am not sure that's what your
problem is.)

On Tue, Mar 6, 2012 at 12:21 AM, Robert Newson <rnewson@apache.org> wrote:
> Could you try with curl? It'll make it easier to diagnose.
>
> B.
>
> On 5 March 2012 17:05, Alexander Gabriel <alex@barbalex.ch> wrote:
>> yep, I can't tell anything illegal about it.
>> and I have been using it for a while now, while replicating worked
>> I am very positive that nothing in the way I replicate in futon has
>> changed, including path and name.
>>
>> Alex
>>
>>
>>
>> 2012/3/5 Robert Newson <rnewson@apache.org>
>>
>>> illegal_database_name points pretty solidly to the problem, though
>>> 'evab' looks like a legal dbname to me...
>>>
>>> B.
>>>
>>> On 5 March 2012 16:23, Alexander Gabriel <alex@barbalex.ch> wrote:
>>> > Hi Robert
>>> >
>>> > Didn't see how to copy the output from futon, so here's a link to the
>>> png:
>>> > www.barbalex.ch/downloads/error.PNG
>>> >
>>> > Alex
>>> >
>>> >
>>> >
>>> > 2012/3/5 Robert Newson <rnewson@apache.org>
>>> >
>>> >> Hi,
>>> >>
>>> >> I believe attachments are stripped by the mailing host software, could
>>> >> you inline it or use pastebin/friendpaste?
>>> >>
>>> >> B.
>>> >>
>>> >> On 5 March 2012 14:00, Alexander Gabriel <alex@barbalex.ch> wrote:
>>> >> > Hi couchers
>>> >> >
>>> >> > My replication fails with the error attached.
>>> >> > Locally I am using futon on couchdb 1.1.1 on windows 7 in google
>>> chrome.
>>> >> > I am trying to replicate to iriscouch.
>>> >> >
>>> >> > My database is 52 MB big and contains appr. 40'000 docs.
>>> >> >
>>> >> > I have tried to get around this issue by rebuilding the database
using
>>> >> curl
>>> >> > and also pushing my design document directly to iriscouch using
curl.
>>> >> This
>>> >> > works. But replicating should work too, shouldn't it?
>>> >> >
>>> >> > I have also locally created a new database and replicated to this.
>>> This
>>> >> > works.
>>> >> >
>>> >> > Above mentioned is what happens on my notebook. On my desktop pc
>>> >> replication
>>> >> > sometimes works, sometimes not. As far as I can see the desktop
pc has
>>> >> the
>>> >> > same setup as the notebook. Seems to me that replicating from the
>>> >> notebook
>>> >> > has worked sporadically during the last week too.
>>> >> >
>>> >> > I believe the json data in the db is valid. I have tested it as
well
>>> as
>>> >> > possible on jsonlint and the couchapp runs very nicely both locally
>>> and
>>> >> on
>>> >> > iriscouch.
>>> >> >
>>> >> > Could this be:
>>> >> > - a mistake I make?
>>> >> > - a CouchDb issue?
>>> >> > - an iriscouch issue?
>>> >> >
>>> >> > the couchapp is visible
>>> >> > here: http://barbalex.iriscouch.com/evab/_design/evab/index.html(log
in
>>> >> > using user = z and password = z)
>>> >> > the code is here: https://github.com/barbalex/EvabMobile
>>> >> >
>>> >> > thanks for helful pointers!
>>> >> >
>>> >> > Alex
>>> >> >
>>> >>
>>>



-- 
Iris Couch

Mime
View raw message