couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcello Nuccio <marcello.nuc...@gmail.com>
Subject Re: Help installing CouchDB on Ubuntu
Date Sat, 21 Jan 2012 07:06:38 GMT
Randall, I've found the time to test your PPA on Ubuntu Oneiric server 32bit.

Following *exactly* your instructions, I've installed couchdb-1.0.1
from Ubuntu repositories, because you forgot to `apt-get update` after
`apt-add-repository`.

Then I've tried to "dist-upgrade". This went well, but the old service
failed to stop during upgrade. So I had to kill the old process before
starting the new one. However this is not a problem of your PPA.

Then I've run the test suite from Futon and it worked.

Can I suggest to use Upstart instead of the old system? It's trivially
easy to setup, and it's much more reliable. It never happened to me
that stopping of a service fails with upstart. I can send you the
configuration I'm using if you want.

Thanks,
  Marcello

2012/1/20 Randall Leeds <randall.leeds@gmail.com>:
> The Ubuntu instructions are the wiki are incredible difficult to
> follow because things have changed in the Ubuntu repositories, mostly
> around SpiderMonkey, and it's really hard to communicate it all in the
> wiki. I've tried and I've edited that page a number of times but I
> know there are problems... I'll comb back through it. Sorry for that.
>
> I wish I had caught this thread earlier, but if you wouldn't mind
> testing out my PPA for Ubuntu, that would be great. It should install
> 1.1.1 on any Natty with no trouble.
>
> $ apt-get install python-software-properties             <- needed for
> next command
> $ apt-add-repository ppa:randall-leeds/couchdb
> $ apt-get install couchdb
> $ update-rc.d couchdb defaults     <- start at startup
>
> I haven't put this on the wiki because I haven't received feedback yet
> from people tell me it worked for them.
>
> -Randall

Mime
View raw message