couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jay Zamboni <jzamb...@vretina.com>
Subject Unable to delete a document
Date Wed, 14 Dec 2011 17:06:04 GMT
While implementing conflict resolution in our application it appears I
created a bad document.  A bug in my code seems to have written the
_conflicts data from an old rev that had a conflict into the head document.
 When viewing the document from the database listing screen in futon I see
the document and its _conflicts field.

Now that I have this condition, I can't seem to get rid of the document
using either the REST API or futon.  When trying to delete the document I
get an error "Document update conflict".

Another odd thing is that using Futon I can see the document on the listing
page with one rev, but when I edit the document I see an earlier rev.  If I
delete it in Futon I get the same conflict error.  If I use javascript to
delete either of the revs I get the same error.  I tried updating the
document with _conflicts set to null, but that did not work either.

I am in the testing phase, so I assume I can just delete the database and
everything will be fine.  However, if something like this ever happens
after we go to production I would like to be able to resolve the issue.

Does anyone have any ideas?  I am using couchdb 1.0.2.

Thanks

Jay

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message