couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Travis Paul>
Subject Re: ssl problem
Date Thu, 24 Nov 2011 18:16:40 GMT
I have only tried a self signed certificate w/ couch. I added my steps
Maybe it might show you something that you have misconfigured?

Best of luck!

On Nov 24, 2011 1:00 PM, "Jeremy Smith" <> wrote:


I have a godaddy ssl certificate and I am not sure how to tell couch to use
the intermediate certificate, there are two settings in local.ini for the
key and the certificate, I have tried various combination of these files
copncatinated in various ways with no joy.

The files I have are:
gd_bundle.crt - bundle provided by godaddy - domain cert provided by godaddy
server.key - my key that I used to create the certificate request

The errors I am getting are:
jeremy@jeremythings:~/daddyssl/blah$ curl -k -v
* About to connect() to port 6984 (#0)
*   Trying connected
* Connected to ( port 6984 (#0)
* successfully set certificate verify locations:
*   CAfile: none
  CApath: /etc/ssl/certs
* SSLv3, TLS handshake, Client hello (1):
* Unknown SSL protocol error in connection to
* Closing connection #0
curl: (35) Unknown SSL protocol error in connection to


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message