couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filipe David Manana <fdman...@apache.org>
Subject Re: replicator database is missing design docs
Date Wed, 02 Nov 2011 11:15:45 GMT
Add a user_ctx top level property to the replication document:

"user_ctx": { "roles": [ "_admin" ] }

You can read about it at https://gist.github.com/832610 (the couch wiki
points to it somewhere).

On Wednesday, November 2, 2011, Benoit Chesneau <bchesneau@gmail.com> wrote:
> On Wednesday, November 2, 2011, Dan Everton <dan@iocaine.org> wrote:
>> On Wed, Nov 2, 2011 at 3:43 PM, James Marca <jmarca@translab.its.uci.edu>
> wrote:
>>> Hi All,
>>>
>>> I am using the new-ish CouchDB replicator database documented here
>>> <http://wiki.apache.org/couchdb/Replication#Replicator_database>.
>>>
>>> Today I noticed that my design docs are not replicating with this
>>> mechanism.  The data copies fine, but the design docs do not.
>>
>> Huh, I was just looking in to this exact problem today with a 1.1.1
>> install as well. We have a master/slave setup with the slave pulling
>> continuously from the master. The _design documents never seem to
>> replicate to the slave and there's no errors in the logs. I've checked
>> for conflicts and other things and also recreated the slave from
>> scratch and still nothing.
>>
>> At least it seems like I'm not alone.
>>
>> Cheers,
>> Dan
>>
>
> did you try to replicate them with an admin user? If the problem persist
> anyway, please open a ticket.
>
> benoƮt
>
> - from my mobile
>

-- 
Filipe David Manana,

"Reasonable men adapt themselves to the world.
 Unreasonable men adapt the world to themselves.
 That's why all progress depends on unreasonable men."

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message