couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Koji Kawamura <ijokaruma...@gmail.com>
Subject Futon Test Suites Failed: CouchDB 1.1.0 FF5.0
Date Wed, 12 Oct 2011 21:25:58 GMT
Hi,

I've been trying to pass all tests but I still get failed.

I installed CouchDB 1.1.0 from tarball following to this installation guide.
"Building CouchDB from source (with EPEL packages)"
http://wiki.apache.org/couchdb/Installing_on_RHEL5

I'm using CentOS 5.7 as a VM hosted on Windows 7.

When I run the test suites from FireFox 5.0,
I got these failures:


attachment_paths	error	4700ms	
    Exception raised: {}

form_submit	error	415ms	
    Exception raised: {}

invalid_docids	error	836ms	
    Exception raised: {}

oauth	error	10849ms	
    Exception raised: {"error":"db_not_found","reason":"could not open
http://couchdb:5984/test_suite_db_a/"}

replication	error	17703ms	
    Exception raised: {"error":"db_not_found","reason":"could not open
http://couchdb:5984/test_suite_db_b/"}

replicator_db	error	10891ms	
    Assertion failed: copy !== null
    Exception raised: {"message":"copy is
null","fileName":"http://couchdb:5984/_utils/script/couch_test_runner.js?0.11.0","lineNumber":143,"stack":"filtered_replication()@http://couchdb:5984/_utils/script/couch_test_runner.js?0.11.0:143\u000arun_on_modified_server([object
Array],filtered_replication)@http://couchdb:5984/_utils/script/couch_test_runner.js?0.11.0:375\u000a(false)@http://couchdb:5984/_utils/script/couch_test_runner.js?0.11.0:737\u000arun(-2)@http://couchdb:5984/_utils/script/couch_test_runner.js?0.11.0:91\u000a"}

security_validation	error	17461ms	
    Exception raised: {"error":"db_not_found","reason":"could not open
http://couchdb:5984/test_suite_db_b/"}

stats	failure	40474ms	
    Assertion 'triggered, "We managed to force a all_dbs_active
error."' failed: We managed to force a all_dbs_active error.

view_compaction	failure	3616ms	
    Assertion failed: resp.view_index.disk_size < disk_size_before_compact

view_errors	error	1890ms	
    Exception raised: {}

69 of 69 test(s) run, 10 failures (634302 ms)

Does anyone have the same experience and know a workaround for this?
Any information is appreciated.

Thanks,
Koji

Mime
View raw message