couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CGS <>
Subject Re: Help installing CouchDB on Ubuntu
Date Wed, 26 Oct 2011 19:18:02 GMT
So, Ubuntu 11 doesn't have any CouchDB package? Strange. Because Ubuntu 
10 has CouchDB 0.9.

Vince, what you did is correct, only that you need to install CouchDB 
before. Using build-couchdb may not put it in the correct path for you 
to follow those instructions. If you want to run it as user and you use 
build-couchdb, then you don't need anymore those steps. Just don't 
forget to start CouchDB with -b option (given that build-couchdb will be 


On 10/26/2011 08:27 PM, kowsik wrote:
> Try this: Uses build-couchdb from
> @iriscouch to build everything from source, configure couchdb, hookup
> logrotate, etc.
> K.
> ---
> @pcapr
> On Wed, Oct 26, 2011 at 11:15 AM, Vince Cardillo<>  wrote:
>> Hi all,
>> I wanted to install CouchDB on the free tier of Amazon Web Services so that
>> I could play wiht and explore it.
>> I was following these instructions:
>> The 2nd line says this: Start the Ubuntu 8.10 server image, ami-5059be39
>> I searched for that image, and it isn't found in the AWS EC2 listing. So I
>> instead installed Ubuntu 11.10 (GNU/Linux 3.0.0-12-virtual i686) (AMI ID:
>> ami-2e90242f).
>> I got through most of the steps, until I hit this step:
>> sudo adduser --system --home /usr/local/var/lib/couchdb
>> --no-create-home --shell /bin/bash --group --gecos 'CouchDB account'
>> couchdb
>> It specifies a home directory, but then has the no-create-home flag, and so
>> at the end it says "not creating home directory". The next command results
>> in this error:
>> chown: cannot access `/usr/local/var/lib/couchdb': No such file or directory
>> This command is listed as optional:
>> sudo vim /usr/local/etc/couchdb/local.ini
>> However, that directory doesn't exist.
>> One more thing. If I run "whereis yum" I get this: yum: /usr/bin/yum
>> /etc/yum /usr/share/man/man8/yum.8.gz
>> If I run "whereis couchdb" I get this: couchdb:
>> Step 8 says: sudo -i -u couchdb couchdb
>> I do that and get this:
>> sudo: unable to change directory to /usr/local/var/lib/couchdb: No such file
>> or directory
>> sudo: unable to execute /bin/bash: No such file or directory
>> Right now I am pretty stuck. I am not sure if couchdb installed correctly or
>> not via the prior steps. And I am not really sure where it is, how to
>> start/stop it, etc. Help is very appreciated!
>> Thank you for any help,
>> - vince

View raw message