couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CGS <cgsmcml...@gmail.com>
Subject Re: Futon Test Suites Failed: CouchDB 1.1.0 FF5.0
Date Fri, 21 Oct 2011 08:48:01 GMT
Sorry, a mistake: instead of "the last version" I wanted to say "the 
latest version".

On 10/21/2011 10:43 AM, CGS wrote:
> That's more a FF problem than CouchDB problem (as you noticed by using 
> someone else's FF). Some recommendations for this case:
> 1. Do not reinstall FF, but remove old FF completely from your PC and 
> install it again from scratch (preferably the last version). If you 
> don't know where FF installed all its folders, the fastest way to 
> clean your system of FF is through system registry (try not to mess up 
> your registries though).
> 2. If it was installed as admin, check if your FF can access all its 
> required files (I am no expert in MS Windows 7 and, actually, I only 
> saw it on one PC, but I know that under Linux, this problem may 
> trigger that kind of errors).
>
> Cheers,
> CGS
>
>
>
>
> On 10/21/2011 09:57 AM, Koji Kawamura wrote:
>> Thank you, CGS
>>
>> The "db_not_found" error turned out to be a problem of hosts file 
>> setting.
>>
>> I was accessing CouchDB (vm) from Windows 7 (host) with "couchdb" as
>> hostname like:
>> http://couchdb:5984/_utils/
>> But I didn't set hosts file on the vm properly.
>> VM sends a replicationrequest,
>> but it couldn't understand the hostname, "couchdb" and failed.
>> After I fixed the hosts file, those tests succeeded.
>>
>> I still get some errors yet,
>> form_submit, view_errors often fail, sometimes succeed, saying this
>> error message:
>> "Exception raised: {}"
>> I debugged the test Javascript and caught this exception:
>> [Exception... "Component returned failure code: 0x80004005
>> (NS_ERROR_FAILURE)" nsresult: "0x80004005 (NS_ERROR_FAILURE)"
>> location: "JS frame ::
>> http://couchdb:5984/_utils/script/couch.js?0.11.0 ::<TOP_LEVEL>  ::
>> line 416" data: no] { message="Component returned fail...4005
>> (NS_ERROR_FAILURE)", result=2147500037, more...}
>> When I use my colleagues' FireFox, these test succeed always.
>> It's because of my local environment setting..
>> I've re-installed FireFox, but the situation didn't change.
>>
>> Thanks,
>> Koji
>>
>> On Thu, Oct 13, 2011 at 3:21 PM, CGS<cgsmcmlxxv@gmail.com>  wrote:
>>> Hi,
>>>
>>> Try to add manually the two databases and see what is happening.
>>>
>>> Cheers,
>>> CGS
>>>
>>>
>>> On 10/12/2011 11:29 PM, Koji Kawamura wrote:
>>>> Excuse me, I made a mistake with the title I followed.
>>>> I followed this one,
>>>> "Building CouchDB from source (with standard packages only)"
>>>>
>>>> On Thu, Oct 13, 2011 at 6:25 AM, Koji Kawamura<ijokarumawak@gmail.com>
>>>>   wrote:
>>>>> Hi,
>>>>>
>>>>> I've been trying to pass all tests but I still get failed.
>>>>>
>>>>> I installed CouchDB 1.1.0 from tarball following to this installation
>>>>> guide.
>>>>> "Building CouchDB from source (with EPEL packages)"
>>>>> http://wiki.apache.org/couchdb/Installing_on_RHEL5
>>>>>
>>>>> I'm using CentOS 5.7 as a VM hosted on Windows 7.
>>>>>
>>>>> When I run the test suites from FireFox 5.0,
>>>>> I got these failures:
>>>>>
>>>>>
>>>>> attachment_paths        error   4700ms
>>>>>     Exception raised: {}
>>>>>
>>>>> form_submit     error   415ms
>>>>>     Exception raised: {}
>>>>>
>>>>> invalid_docids  error   836ms
>>>>>     Exception raised: {}
>>>>>
>>>>> oauth   error   10849ms
>>>>>     Exception raised: {"error":"db_not_found","reason":"could not 
>>>>> open
>>>>> http://couchdb:5984/test_suite_db_a/"}
>>>>>
>>>>> replication     error   17703ms
>>>>>     Exception raised: {"error":"db_not_found","reason":"could not 
>>>>> open
>>>>> http://couchdb:5984/test_suite_db_b/"}
>>>>>
>>>>> replicator_db   error   10891ms
>>>>>     Assertion failed: copy !== null
>>>>>     Exception raised: {"message":"copy is
>>>>>
>>>>> null","fileName":"http://couchdb:5984/_utils/script/couch_test_runner.js?0.11.0","lineNumber":143,"stack":"filtered_replication()@http://couchdb:5984/_utils/script/couch_test_runner.js?0.11.0:143\u000arun_on_modified_server([object

>>>>>
>>>>>
>>>>> Array],filtered_replication)@http://couchdb:5984/_utils/script/couch_test_runner.js?0.11.0:375\u000a(false)@http://couchdb:5984/_utils/script/couch_test_runner.js?0.11.0:737\u000arun(-2)@http://couchdb:5984/_utils/script/couch_test_runner.js?0.11.0:91\u000a"}

>>>>>
>>>>>
>>>>> security_validation     error   17461ms
>>>>>     Exception raised: {"error":"db_not_found","reason":"could not 
>>>>> open
>>>>> http://couchdb:5984/test_suite_db_b/"}
>>>>>
>>>>> stats   failure 40474ms
>>>>>     Assertion 'triggered, "We managed to force a all_dbs_active
>>>>> error."' failed: We managed to force a all_dbs_active error.
>>>>>
>>>>> view_compaction failure 3616ms
>>>>>     Assertion failed: resp.view_index.disk_size<    
>>>>> disk_size_before_compact
>>>>>
>>>>> view_errors     error   1890ms
>>>>>     Exception raised: {}
>>>>>
>>>>> 69 of 69 test(s) run, 10 failures (634302 ms)
>>>>>
>>>>> Does anyone have the same experience and know a workaround for this?
>>>>> Any information is appreciated.
>>>>>
>>>>> Thanks,
>>>>> Koji
>>>>>
>>>
>


Mime
View raw message