couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clarke Bishop" <>
Subject RE: Help installing CouchDB on Ubuntu
Date Thu, 27 Oct 2011 00:51:29 GMT
I did try couchbase singer server, but had problems with it. Does it work
with Ubuntu? Which versions?


I'd just like to know about a combination that can definitely work. Then,
I'll troubleshoot if needed. I've just been spinning my wheels trying all
sorts of combinations.


Thanks for your ideas!




From: Robert Wadholm [] 
Sent: Wednesday, October 26, 2011 8:37 PM
Subject: Re: Help installing CouchDB on Ubuntu


Hi Clarke,

Have you already tried CouchBase Single Server Community Edition for Linux?

Might be the easier way to go if you want a packaged deal.




Bob Wadholm

GitHub (


On Oct 26, 2011, at 6:29 PM, Clarke Bishop wrote:


This is all very frustrating. Couchdb is wonderful, but not if you can't
install it. 

build-couchdb at looks great. It
says it works on Ubuntu 10.04 LTS (Lucid Lynx). If I roll back to that
version of Ubuntu, will I be relatively safe? I know nothing's perfect. I
just want to have a good chance to succeed.

I tried a bunch of things that were suggested the other day, but couldn't
get anything to work.

I'd like to use Ubuntu. Is there a version, any version, of Ubuntu that has
a reliable couchdb install? 

Please forgive me for complaining. I know all of you and the couchdb dev
team are working hard to do great stuff. I want to do great stuff with
couchdb, but I'm stuck. Before, I thought it was just me and my newbie-ness.
But, it doesn't seem like anyone can get this to work.

Thanks for any help!


-----Original Message-----
From: john.tiger [] 
Sent: Wednesday, October 26, 2011 8:08 PM
Subject: Re: Help installing CouchDB on Ubuntu

I believe that programmers ought to be able to upgrade / build packages 
so we should be able to get 1.1.0 downloaded and working (with 1.1.1 
soon on the way)

But I just spent the last few hours trying to update my 11.10 to Couch 
1.1.0 which the wiki suggests - I tried to follow someone's instructions 
for building 1.1.0 in 11.04 but now Ubuntu no longer has xulrunner in 
the repositories (frustrating!)

so question is :
a) should we download xulrunner-1.9.2-dev from Natty repository and use 
in 11.10 ?
b) Debian shows no xulrunner-1.9.2 but does show 1.9.1.x and 2.0 in 
experimental - should we use that ?
c) if there's not a good reason for ubuntu to start dumping key packages 
should we switch to Linux Mint with debian testing ?

or should Couch get out of the xulrunner dependency ?

On 10/26/2011 01:50 PM, CGS wrote:

Even if it is recommended the latest version, if something is working, 

do not touch it unless you know what you do or you are forced to do 

it. That's my sincere piece of advice.


If you installed it from "Batteries Included", then you should have 

default.ini and under /etc/couchdb/, and the couchdb daemon 

under /etc/init.d/. You don't need anything else (no extra user, no 

extra building) but to configure it for your needs (in the ini's 

files). If you have problems in starting/stopping/restarting and so 

on, just type man couchdb and press enter (use stop and start after 

few seconds to be sure you restart it correctly - sometimes Erlang 

processes tend to report stop while they are still in the process of 

stopping). Check this out to start using CouchDB:


and if you forget the commands there, just take a look into the short 

version of that documentation:


So, sit back and relax while reading about couch. :)


Welcome to this community!







On 10/26/2011 09:31 PM, Vince Cardillo wrote:

Hi All,


I was able to get CouchDB 1.0.1 installed and running via these

instructions: I

followed the very top "Batteries Included" instructions.


I'm a little wary to try and upgrade it though--I'm about one step up 

from a

Linux noob. It's been a while.


whereis couchdb

couchdb: /usr/bin/couchdb /etc/couchdb /usr/lib/couchdb 




I am not sure how I would upgrade it.


- vince




On Wed, Oct 26, 2011 at 3:18 PM, CGS<>  wrote:


So, Ubuntu 11 doesn't have any CouchDB package? Strange. Because 

Ubuntu 10

has CouchDB 0.9.


Vince, what you did is correct, only that you need to install CouchDB

before. Using build-couchdb may not put it in the correct path for 

you to

follow those instructions. If you want to run it as user and you use

build-couchdb, then you don't need anymore those steps. Just don't 

forget to

start CouchDB with -b option (given that build-couchdb will be 











On 10/26/2011 08:27 PM, kowsik wrote:


Try this:**1171217<>.

Uses build-couchdb from

@iriscouch to build everything from source, configure couchdb, hookup

logrotate, etc.






On Wed, Oct 26, 2011 at 11:15 AM, Vince Cardillo<>



Hi all,


I wanted to install CouchDB on the free tier of Amazon Web 

Services so


I could play wiht and explore it.


I was following these instructions:**couchdb/Getting_started_with_**Amazon_EC2<http://wi> 



The 2nd line says this: Start the Ubuntu 8.10 server image, 



I searched for that image, and it isn't found in the AWS EC2 

listing. So


instead installed Ubuntu 11.10 (GNU/Linux 3.0.0-12-virtual i686) 




I got through most of the steps, until I hit this step:

sudo adduser --system --home /usr/local/var/lib/couchdb

--no-create-home --shell /bin/bash --group --gecos 'CouchDB account'



It specifies a home directory, but then has the no-create-home 

flag, and


at the end it says "not creating home directory". The next command


in this error:


chown: cannot access `/usr/local/var/lib/couchdb': No such file or



This command is listed as optional:

sudo vim /usr/local/etc/couchdb/local.**ini


However, that directory doesn't exist.


One more thing. If I run "whereis yum" I get this: yum: /usr/bin/yum

/etc/yum /usr/share/man/man8/yum.8.gz


If I run "whereis couchdb" I get this: couchdb:


Step 8 says: sudo -i -u couchdb couchdb

I do that and get this:

sudo: unable to change directory to /usr/local/var/lib/couchdb: No 



or directory

sudo: unable to execute /bin/bash: No such file or directory



Right now I am pretty stuck. I am not sure if couchdb installed 



not via the prior steps. And I am not really sure where it is, how to

start/stop it, etc. Help is very appreciated!



Thank you for any help,

- vince







  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message