couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Smith <...@iriscouch.com>
Subject Re: Build error on couch_js/main.c
Date Fri, 02 Sep 2011 23:34:51 GMT
Build CouchDB should never use the system SpiderMonkey, but rather the
one that is bundled in dependencies/js_src. Looking at your logs, it
built spidermonkey already; however, possibly it is not using the
correct version when building couchjs later.

2011/9/2 Daniel Itaboraí <itaborai83@gmail.com>:
> Jason,
>
> Would you like me to test it with or without the system SpiderMonkey?
>
> Daniel
>
> On Fri, Sep 2, 2011 at 10:26 AM, Jason Smith <jhs@iriscouch.com> wrote:
>
>> Hi, Daniel. Thanks for the update.
>>
>> The latest version (that I publish at any rate) is from
>> git://github.com/iriscouch/build-couchdb
>>
>> Would you please try with that version and perhaps attach or paste
>> your rake.log file when the build completes? Thanks!
>>
>> 2011/9/2 Daniel Itaboraí <itaborai83@gmail.com>:
>> > Thanks for the replies.
>> >
>> > Jason,
>> >
>> > I´m using Ubuntu 11.04 64 bits. I am building from the couchone
>> repository
>> > (git://github.com/couchone/build-couchdb). Now I´m not sure about which
>> one
>> > I should be using. I´ve followed the install scripts blindly. I haven´t
>> had
>> > the opportunity(and the know how) to tinker with CouchDB´s build system.
>> >
>> >
>> > Paul,
>> >
>> > You´re definitely right about a pre-existing SpiderMonkey in the system.
>> I
>> > installed it a month ago to test some Javascript code. I guess the next
>> > logical step would be to remove it and try to build it again. As soon as
>> I
>> > get home I´ll try that.
>> >
>> > thanks,
>> > Daniel
>> >
>> > On Fri, Sep 2, 2011 at 2:39 AM, Paul Davis <paul.joseph.davis@gmail.com
>> >wrote:
>> >
>> >> Also if you're not hip to the C, check for things like
>> >> /usr/include/js/jsapi.h or similar. Its likely that your OS has a
>> >> SpiderMonkey that's getting preferred over what's in build-couch.
>> >>
>> >> On Fri, Sep 2, 2011 at 12:29 AM, Jason Smith <jhs@iriscouch.com> wrote:
>> >> > 2011/9/2 Daniel Itaboraí <itaborai83@gmail.com>:
>> >> >> Hi there,
>> >> >>
>> >> >> Not sure if I'm this is the right place, but I'm trying to build
>> CouchDB
>> >> >> using build-couchdb. Unfortunately I'm erroring out while trying
to
>> >> build
>> >> >> couch_js.
>> >> >>
>> >> >> I was wondering if anyone could give me some pointers on what to
do
>> >> next.
>> >> >>
>> >> >> I've paste the output of rake --trace below if it helps
>> >> >>
>> >> >> http://pastebin.com/nMQg6J9i
>> >> >
>> >> > Thanks.
>> >> >
>> >> > Which operating system and version are you on?
>> >> >
>> >> > Are you building from git://github.com/iriscouch/build-couchdb?
>> >> >
>> >> > Did you change to dependencies/couchdb and run any Git commands?
>> >> >
>> >> > I think there is possibly an error beginning from line 211. Usually,
>> >> > when you see a string of bad casts and undeclared identifiers it means
>> >> > a missing or wrong .h file. Hopefully some of your answers will
>> >> > provide a clue.
>> >> >
>> >> > --
>> >> > Iris Couch
>> >> >
>> >>
>> >
>>
>>
>>
>> --
>> Iris Couch
>>
>



-- 
Iris Couch

Mime
View raw message