couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sam Kearns <...@kearns.net.au>
Subject Futon Test Suite Failures
Date Mon, 11 Jul 2011 22:30:35 GMT
Hi All,

First post. Recently discovered CouchDB and have been playing around
with it on my laptop for a couple of weeks. Today I decided to run the
test suite in Futon. (yeah OK I'm lazy, maybe I should say "relaxed" ;) )

My Setup:
Asus EeePC 1000H w/2Gb RAM
Win7 Home Premium 32-bit
Couch DB V1.1.0 as a windows service
Firefox V5.0

The first time I ran the test suite it informed me that I must be in
Admin party mode and offered to delete my admin users for me, which I
accepted.

The tests then proceeded for a little while but eventually I got a FF
dialogue telling me scripts were taking to long to run. I clicked
"Continue" but eventually Firefox totally crashed and had to be
terminated. After restarting FF I also found that CouchDB had totally
crashed (no response on HTTP) so I had to restart that service too.

After getting back into Futon, my CouchDB was now littered with test
databases. I went back to the test page and tried to test again
(thinking it would clean up before/after itself). This time it
completed all the tests without crashing however most of the tests
failed due to an authorisation error telling me I was not an admin. I
figured it must have something to do with the left over databases from
the previous crash so I tried to delete them but could not. Even
though I was in "Admin Party" mode, Futon kept telling me that I could
not delete those databases because I was not an administrator. (WTF?)

So I re-created my user login, but now my new user was not an Admin
either. After a minor panic that I had locked myself out of my CouchDB
I discovered that I could add admins to local.ini. After doing that,
and logging in, I was then able to delete all of the left-over test
databases. I then went back to local.ini and commented out my admin
users and restarted couchDB and confirmed I was back in Admin Party
mode.

I then ran the tests again, this time every single test passed except
for the "attachments" test.


Assertion failed: false
Exception raised: {
"message":"actual is null","fileName":"http://localhost:5984/_utils/
script/couch_test_runner.js?0.11.0 
<http://localhost:5984/_utils/script/couch_test_runner.js?0.11.0>","lineNumber":
322,"stack":"
TEqualsIgnoreCase(\"text/
plain;charset=utf-8\",null)@http://localhost:5984/_utils/script/
couch_test_runner.js?0.11.0:322\u000a(true)@http://localhost:5984/
_utils/script/test/attachments.js:215\u000arun(17)@http://localhost 
<http://localhost:5984/_utils/script/couch_test_runner.js?0.11.0:322%5Cu000a%28true%29@http://localhost:5984/_utils/script/test/attachments.js:215%5Cu000arun%2817%29@http://localhost>:
5984/_utils/script/couch_test_runner.js?0.11.0:91\u000a"}


The odd thing here is that this test had in fact passed on the
previous test run! I then tried clicking "Run with debugger". The same
error is shown again in the "Details" column but the test never
completes, (shows "running" in status column) despite waiting 10+
minutes for it.

Also, even though neither Firefox nor CouchDB crashed, my CouchDB now
has a bunch of left-over test databases in it again. They are:

test_suite_db
test_suite_db/with_slashes
test_suite_filtered_rep_db_a
test_suite_filtered_rep_db_b
test_suite_rep_docs_db_a
test_suite_rep_docs_db_b
test_suite_reports

This time however I was allowed to delete them in Admin Party mode.

Running the test again it fails the attachments test again and also
fails three other tests: auth_cache, list_views and rev_stemming. All
three of these tests passed on 2 previous test runs. in looking at
their error messages they seem completely unrelated to each other.
(i.e. they are not all auth errors or something like that).

So at this point I give up with the test suite. Every time I run I get
different results and it frequently bugs out and can even kill my
browser and my CouchDB service.

Thing is, this is the only time that CouchDB has not been rock solid
for me. I know that's not saying much as I am only developing a
CouchApp for learning and personal use at the moment.

Does it matter that I am running the test suite on a CouchDB install
that already has my app database in it? Or should the test suite only
be run on a clean install?

What should I make of all of this?

Cheers,
Sam

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message