couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randall Leeds <randall.le...@gmail.com>
Subject Re: conflict when deleting a document
Date Fri, 17 Jun 2011 22:37:14 GMT
On Thu, Jun 16, 2011 at 01:31, Bernhard Schauer
<bernhard.schauer@openforce.com> wrote:
> thx Robert. I thought about this, but I would like to keep the design
> documents.
> And as this runs as part of test-setup perfomance is not a big problem.
>

Why not just re-load the design documents in the setup phase of your test?

> On 2011-06-16 10:09, Robert Newson wrote:
>>
>> Why not just delete the database? It'll be faster.
>>
>> B.
>>
>> On 16 June 2011 08:43, Bernhard Schauer<bernhard.schauer@openforce.com>
>>  wrote:
>>>
>>> no, I only have views.
>>>
>>> On 2011-06-16 08:49, Marcello Nuccio wrote:
>>>>
>>>> Do you have validate_doc_update functions in your design documents?
>>>> If yes, does delete works if you remove them?
>>>>
>>>> Marcello
>>>>
>>>> 2011/6/16 Bernhard Schauer<bernhard.schauer@openforce.com>:
>>>>>
>>>>> Hallo all,
>>>>>
>>>>> I have a wired problem when deleting documents. For test purposes I
>>>>> want
>>>>> to
>>>>> delete all documents in a Database, and then insert a well known set
of
>>>>> Documents. I do this using Ektorp (Java).
>>>>>
>>>>> Inserting is no problem. But when it comes to deleting the documents
I
>>>>> get a
>>>>> conflict.
>>>>> What I actually do is get the ids and revisions of all documents (the
>>>>> built-in all view) and put them in a bulk operation to delete them.
>>>>>
>>>>> Interestingly I can not delete those documents via futon either.
>>>>> When query one of those conflicting documents with revs and revs_info
>>>>> it
>>>>> shows me that there is only one revision.
>>>>>
>>>>> Even more funny, I can not reproduce this in a DB that has no views.
>>>>> There
>>>>> it deleting works. The DB I actually want to work with (and that causes
>>>>> the
>>>>> problem) has several design documents with views.
>>>>>
>>>>> Anyone any idea on that?
>>>>>
>>>>> thx Bernhard
>>>>>
>>>>>
>>>>>
>

Can you provide a paste of the error?

Mime
View raw message