couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bade Iriabho <eb...@mathbiol.org>
Subject Re: Installing CouchDB on CentOS 5.6
Date Fri, 06 May 2011 10:43:52 GMT
Thanks. That should get me going. I'll report back with any success stories.

Bade I.
On May 6, 2011 1:30 AM, "Pasi Eronen" <pe@iki.fi> wrote:
> Probably the easiest way is to compile CouchDB yourself.
>
> There's a build-couchdb script at
https://github.com/couchone/build-couchdb,
> which claims to work on RHEL, too.
>
> My production environment doesn't like other repositories than official
> RHEL, so I'm using a simple Makefile to build Erlang, Curl, and CouchDB
> (in a separate directory to avoid conflicts with any RHEL Erlang/Curl
packages),
> with official "libicu" and "xulrunner" packages.
>
> Basically something like this (slightly simplified):
>
> Erlang:
> - untar otp_src_R14B.tar.gz
> - ./configure --prefix=$(DST)/erlang --without-termcap --without-javac
> --enable-smp-support --disable-hipe
> - make && make install
>
> Curl:
> - untar curl-7.21.2.tar.gz
> - ./configure --prefix=$(DST)/curl
> - make && make install
>
> CouchDB:
> - untar apache-couchdb-1.0.2.tar.gz
> - ERL=$(DST)/erlang/bin/erl ERLC=$(DST)/erlang/bin/erlc
> CURL_CONFIG=$(DST)/curl/bin/curl-config LDFLAGS=-L$(DST)/curl/lib
> ./configure --prefix=$(DST)/couchdb
> --with-erlang=$(DST)/erlang/lib/erlang/usr/include/
> --with-js-include=$(XULRUNNER_INCLUDE) --with-js-lib=$(XULRUNNER_LIB)
>
> Best regards,
> Pasi
>
> On Fri, May 6, 2011 at 02:38, Mark Hahn <mark@boutiquing.com> wrote:
>> Good luck with that.  I gave up trying to install couch on centos back in
>> Nov 2010.  The centos libraries were too old and missing too much.  I
posted
>> on several forums for help with no answers.  I switched to ubuntu pretty
>> much to run couch.  The situation may be better now but I doubt it.
>>
>> On Thu, May 5, 2011 at 9:30 AM, Bade Iriabho <ebade@mathbiol.org> wrote:
>>
>>> I am having some issues with installing CouchDB on CentOS 5.6, can
someone
>>> please tell me what repositories or files/dependencies, I should have
>>> before
>>> I install CouchDB 1.0.2. The EPEL repository only has version 0.11. Also
is
>>> there a good tutorial on this somewhere on the web other tha the Couch
>>> Wiki?
>>>
>>> Regards,
>>> Bade I.
>>>
>>
>>
>>
>> --
>> Mark Hahn
>> Website Manager
>> mark@boutiquing.com
>> 949-229-1012
>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message